summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-02 11:59:20 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-02 11:59:20 +0100
commitb6dbba52f2c173c052e10a5b64051160bd6af1e9 (patch)
tree6f737165ffaf4ee9b80f0be28a689de4e62e92f3
parentdev-python/pyopencl: stabilize 2022.1.6 for amd64 (diff)
downloadgentoo-b6dbba52.tar.gz
gentoo-b6dbba52.tar.bz2
gentoo-b6dbba52.zip
dev-python/pyopencl: drop 2022.1.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2022.1.5.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index bf404f74cf95..5f61f35b51dc 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,2 +1 @@
-DIST pyopencl-2022.1.5.tar.gz 454129 BLAKE2B 266bc327c9af5654287fc47cdf4e6002c7cddcd6f5e55bb70bb62aaee666dc5c102f78d4e946f010c1e109390c1d2e981e7ca6ca002d10f66248cb008b308734 SHA512 e6eb3e6d886d8ca1d94867a398b286556fd2d93535bb8481c7603cd521cd47606ce3d9cd6422830c6404305a4a1293234d8774fdda6923bdd2b4fc21fb39d377
DIST pyopencl-2022.1.6.tar.gz 455424 BLAKE2B 03c46bebc4d6093489b0a1501267d5d67b73e9e7fe50f73cec3dd752fbb699adab63e08d60f3a54c8fd215cbb82c81353d28e875b953686b05e188df78cfe237 SHA512 a1e404c4c5f95d111690c969ae5c5d34f0deca2c8b93a5ce4d90e003031af7eb94a7708f878170a9b6e001b899d321f7dfdaa6f7545af3237d30d237d44bb45f
diff --git a/dev-python/pyopencl/pyopencl-2022.1.5.ebuild b/dev-python/pyopencl/pyopencl-2022.1.5.ebuild
deleted file mode 100644
index b6ce5908fee9..000000000000
--- a/dev-python/pyopencl/pyopencl-2022.1.5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples opengl"
-
-DEPEND=">=virtual/opencl-2"
-RDEPEND="${DEPEND}
- >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
-# libglvnd is only needed for the headers
-BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
- <dev-python/pybind11-2.10.0[${PYTHON_USEDEP}]
- opengl? ( media-libs/libglvnd )"
-
-# The test suite fails if there are no OpenCL platforms available, and
-# even if there is one (which requires the presence of both an OpenCL
-# runtime *and* hardware supported by it - simply emerging any runtime
-# is not enough) the vast majority of tests end up skipped because by
-# default the portage user hasn't got sufficient privileges to talk
-# to the GPU.
-RESTRICT="test"
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}