summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-05-26 11:56:24 -0300
committerMatt Turner <mattst88@gentoo.org>2023-05-26 15:18:30 -0400
commitb6df2e5ee62c9c7cd0871aabd2fd28ee17e34a48 (patch)
treef6261487e70424febe2ac3c6df88936756e3d6d7
parentgnome-extra/evolution-ews: Version bump to 3.48.2 (diff)
downloadgentoo-b6df2e5ee62c9c7cd0871aabd2fd28ee17e34a48.tar.gz
gentoo-b6df2e5ee62c9c7cd0871aabd2fd28ee17e34a48.tar.bz2
gentoo-b6df2e5ee62c9c7cd0871aabd2fd28ee17e34a48.zip
sci-geosciences/gnome-maps: Version bump to 44.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31172 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-44.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 7afecc518b98..45fd384deb96 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1 +1,2 @@
DIST gnome-maps-44.1.tar.xz 2349152 BLAKE2B e544427972f98d13c5c072c234006c081fc000048956cdd795f47225bc73771d655f048bd3ca7d2478f9afd23d50b6f26df95a08ec24b92c1d80a2280a9d2f60 SHA512 918a490491b86aa2648dae844dd910be5e4dff339544a6286d35c341bb11acfa1587de04fe2f2b3aff46c57c4175fc0bad50c28a253ffea8bacf274c0ca42f72
+DIST gnome-maps-44.2.tar.xz 2349116 BLAKE2B 52fd29cfa89ab76c6b041d9ae77453b75e5f9d2fe2de12d0ba1f283c4d16920156e9dffd54dfd0add9a37e66c3a4c49bb4ad43d4733f41301325f281e15fe458 SHA512 ea435f3a5a3ed9e4c3054e3fbb2f3dad253f0150f7555c734d06db3a039ece356c61294a664945b5165b004001d8724428aaed527ba0ca55fae2f7d37833e6a7
diff --git a/sci-geosciences/gnome-maps/gnome-maps-44.2.ebuild b/sci-geosciences/gnome-maps/gnome-maps-44.2.ebuild
new file mode 100644
index 000000000000..b7701c61f77d
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-44.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.0:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ >=media-libs/libshumate-1.0:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}