summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-17 07:07:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-17 08:54:21 +0200
commitb6e841f6e2e2a9e90caad27089e71cb77d69a66b (patch)
treea819e38fa1f5dea86ae0919297ccfd13e31ec925
parentapp-admin/awscli: Bump to 1.24.1 (diff)
downloadgentoo-b6e841f6.tar.gz
gentoo-b6e841f6.tar.bz2
gentoo-b6e841f6.zip
dev-python/ansible-compat: Bump to 2.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.0.4.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 4ee1bfe9fd47..dd9e7faa3d5b 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1 +1,2 @@
DIST ansible-compat-2.0.3.tar.gz 35328 BLAKE2B cd5a476eb23de667381c9a6667d6bd781821fc50e1aec65ca47e8bb9d47beccbea0ee62f763ed421c18c95d9f1d1c14f5cc2a62bcc77d664213eb614ccd568e4 SHA512 0887e5da23041d02be0371bfd9569256252c586f80cd92ab855b32172328989c8160e57169aff6d72f1c3c89c9d3a00b56293e3badc0dc4aad135b1992d06599
+DIST ansible-compat-2.0.4.tar.gz 35447 BLAKE2B 53aa93ef3144071c2d9022bce99c6d20a67650fa98a6896db4fd1c866ada292390cc8e6bb6e7bd3b2b05cef8b3cab2803522ca1bbb7dbacb7b9da29b16f1fbb7 SHA512 8fd6738cf2caf4cae3590e839edd76fdb21ebbb88f50bda470e6711fda4ac8ef18eded3ae4ff72e3b53925afc5649658892e434da943ebd7e986d18afe9cc6af
diff --git a/dev-python/ansible-compat/ansible-compat-2.0.4.ebuild b/dev-python/ansible-compat/ansible-compat-2.0.4.ebuild
new file mode 100644
index 000000000000..5b3828e761ae
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-2.0.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-base-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+distutils_enable_sphinx docs \
+ dev-python/ansible-pygments \
+ dev-python/myst_parser \
+ dev-python/sphinx_ansible_theme
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytest_markdown.plugin
+}