summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-10 20:37:28 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-10 20:39:09 +0100
commitb6f67945fcdc102231048d2c03538a29635342d6 (patch)
tree95b3aa883d0c3840487122099d3a21e48c5e1db5
parentapp-admin/puppet-agent: stabilize 7.23.0 for amd64 (diff)
downloadgentoo-b6f67945fcdc102231048d2c03538a29635342d6.tar.gz
gentoo-b6f67945fcdc102231048d2c03538a29635342d6.tar.bz2
gentoo-b6f67945fcdc102231048d2c03538a29635342d6.zip
dev-qt/qtimageformats: Really bump to QT5_KDEPATCHSET_REV=2
Bug: https://bugs.gentoo.org/900358 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtimageformats/Manifest1
-rw-r--r--dev-qt/qtimageformats/qtimageformats-5.15.8-r2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtimageformats/Manifest b/dev-qt/qtimageformats/Manifest
index dfbcfe603ad7..430562fe308d 100644
--- a/dev-qt/qtimageformats/Manifest
+++ b/dev-qt/qtimageformats/Manifest
@@ -1,3 +1,4 @@
DIST qtimageformats-5.15.8-gentoo-kde-1.tar.xz 5000 BLAKE2B 1d1a5054267bf8e28051e4bdd6e2cb62f59dfc386d3d888071bab74fe818b7daec46baf9f9cd7d8bfad3e179c2d2c811e983008a7451255cf450f733988f3bb8 SHA512 68da3c1ee6f33dfdadd6e1ec7bca6a7c0f16671ebed232a4c12aac4d4fe2e61295901082362efd0b4e69c5576b35370a92063630da251bd71ff7d275825400d9
+DIST qtimageformats-5.15.8-gentoo-kde-2.tar.xz 6964 BLAKE2B 934e35ef39ba3e41d87842d5883cfef1e21f36fa3abbe20851cef33c4b652eab74b4dc704b926aaaecf6927183a36167c0879593511bf143749e51cea82feee9 SHA512 a5d1e3ef2706e4d28f0f72199f422c3c41b11836bbafee6800cfb498e242c3587c8d076ca1770e5b88e1b18590ef0a3e0bb98328aa87524c6f4c7ac385b995bb
DIST qtimageformats-everywhere-opensource-src-5.15.8.tar.xz 1843016 BLAKE2B 55f4a0b212e63483d23a8a962ffafd826994088e00025291a502d371540e2d88217f5caeea03d40347ff756033b47ffa71e1e250673b977013b7dd5d190b0e7c SHA512 e601a1ebd0881e59c1f87df748faf63df12f552fe668d16af27a58421848ba4de822b4dc3fc54f23c17b818408b6af2edbfb0b59c29e7da8a272d25ac51d7cdd
DIST qtimageformats-everywhere-src-6.4.2.tar.xz 1938812 BLAKE2B 65d1e5e7c415397cb411acc60fdb7ba316e986de30eb23a14c92f4fa6d3280bbb7aab2e592fd6d360052ba757472e8fd0aa35212fa3be545e07a4714bfe93ac7 SHA512 2bda0001295d1a27ee3018d7a7236525ee41f7de33d58805a71277b5a7d8f9506687a7bb9d6630e32cbcb89e340048591e9f9d29833a3bb4d8168c4779dc5320
diff --git a/dev-qt/qtimageformats/qtimageformats-5.15.8-r2.ebuild b/dev-qt/qtimageformats/qtimageformats-5.15.8-r2.ebuild
new file mode 100644
index 000000000000..be4f67c0b874
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-5.15.8-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=2
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+IUSE="mng"
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ media-libs/libwebp:=
+ media-libs/tiff:=
+ mng? ( media-libs/libmng:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ sed -e 's/qtConfig(jasper)/false:/' \
+ -i src/plugins/imageformats/imageformats.pro || die
+ qt_use_disable_config mng mng src/plugins/imageformats/imageformats.pro
+
+ qt5-build_src_configure
+}