summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-14 06:42:36 +0000
committerSam James <sam@gentoo.org>2021-12-14 06:44:08 +0000
commitb70e6f910846d25635a6d0e88686ce2144842f02 (patch)
tree0fdc54a0da64a57dded9e94322cfe526b983eddd
parentdev-perl/XML-Parser: use system copy of Devel::CheckLib (fix Expat search) (diff)
downloadgentoo-b70e6f91084.tar.gz
gentoo-b70e6f91084.tar.bz2
gentoo-b70e6f91084.zip
dev-perl/RPC-XML: Revert "Remove old", drop 0.820.0 back to ~arch
This reverts commit ed0ac19462a2943678f6e67082f45c75ef10af4d. Restore older for now so we can keep older XML-Parser while we investigate issues w/ it and Expat. Bug: https://bugs.gentoo.org/827966 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-perl/RPC-XML/Manifest1
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild62
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild2
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-perl/RPC-XML/Manifest b/dev-perl/RPC-XML/Manifest
index f897b567eb31..b2c4efa1e906 100644
--- a/dev-perl/RPC-XML/Manifest
+++ b/dev-perl/RPC-XML/Manifest
@@ -1 +1,2 @@
+DIST RPC-XML-0.80.tar.gz 211223 BLAKE2B e26ba4f667c227e84362ca8e09d17ee01ef45c25902e7bc433bc4a81facacfc6163fc06ddd20a08399131faf18daa97f0f1a173043147f2d5046424c6e3087d3 SHA512 a91586ea903b3e633f85ca8d9048181a7c3aedcff6788c7ae5fb4971e8552c421c86f30254517c25caa35f1991146dcceb34301bb49002e4ec75a2ee9c195992
DIST RPC-XML-0.82.tar.gz 225690 BLAKE2B 4e16730a5bda313d43b00eaa8617e009a157867f286f17afb58693beb881ac2329ebee93d98c44c8742be2608998c1d2e0cc4f323be83ae9c5e9041c5bf90b3c SHA512 e5d1092a2807c2bd423502dd2ed53a72c57384b67bb4709e86a64a6fe37ce8af580998e62fcfa6a48d66d5308d9dc270c74e4293617b9f23a654e379cde4025f
diff --git a/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild
new file mode 100644
index 000000000000..90f2ade1ff82
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.800.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJRAY
+DIST_VERSION=0.80
+DIST_EXAMPLES=( "ex/*.xpl" )
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="amd64 ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-0.800.0
+ >=dev-perl/libwww-perl-5.834.0
+ >=virtual/perl-Module-Load-0.240.0
+ >=virtual/perl-Scalar-List-Utils-1.200.0
+ >=dev-perl/XML-LibXML-1.850.0
+ >=dev-perl/XML-Parser-2.310.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/HTTP-Daemon
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"
+
+src_compile() {
+ perl-module_src_compile
+ if use examples; then
+ pushd "${S}/ex" >/dev/null || die "Can't enter ${S}/ex"
+ emake MAKEMETHOD="${S}/blib/script/make_method"
+ popd >/dev/null || die "Can't exit ${S}/ex"
+ fi
+}
+pkg_postinst() {
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "${SETWARN}" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}
diff --git a/dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild
index c6b534d0c768..d58d5f0bd422 100644
--- a/dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild
+++ b/dev-perl/RPC-XML/RPC-XML-0.820.0.ebuild
@@ -12,7 +12,7 @@ DESCRIPTION="An implementation of XML-RPC"
SLOT="0"
LICENSE="|| ( Artistic-2 LGPL-2.1 )"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"