summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-02 23:47:17 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-02 23:47:17 +0200
commitb71258ebfa09ead655ebec6954e03387d040cc01 (patch)
treec46f345f086c5d6c9e3674a24ab8078d07862554
parentx11-libs/goffice: add 0.10.52 (diff)
downloadgentoo-b71258eb.tar.gz
gentoo-b71258eb.tar.bz2
gentoo-b71258eb.zip
app-office/gnumeric: add 1.12.52
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.52.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 4ce77f8d40f6..7a837233ec6d 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1 +1,2 @@
DIST gnumeric-1.12.51.tar.xz 18117120 BLAKE2B 7d30dc01cda93a99ef8d47ccdf6bcfd1b6b6964a806599c7ade486f9bbfb61a876ef942174425cb2f59e018f5ec95a9df36a9deb0cd67d23e1801c2c289d83bd SHA512 c46164d9deb29831ab059613548743d84cb15461ac363305a28097832eb69d3fbf3cf8784c420c777bd09e32212b2ef6237bfa56ca28a7e08fd3befde9dfed36
+DIST gnumeric-1.12.52.tar.xz 18115444 BLAKE2B 6d8489c27b6f7bd0ffad7d255b606a48ca9660dd38973e4bb529d38797a3029db4a0a399e40f69c84ddf33b96d27cfc184fd079fbe16590b92e056c1a836b037 SHA512 3baa2d2c4ed5f740429454f988ea527991febf38f49df17f0d88affe501c676bae95149fb0cdb4b369ef8d32247c1f4fe4c0eeab9a60329e1332aaf9c566f868
diff --git a/app-office/gnumeric/gnumeric-1.12.52.ebuild b/app-office/gnumeric/gnumeric-1.12.52.ebuild
new file mode 100644
index 000000000000..b11b523b71ae
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.52.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit gnome.org libtool python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.51:0.10[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}