summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-30 15:28:50 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-30 15:29:39 +0100
commitb730a5be0e15eac40a0c0948820ae7bdb7fa780e (patch)
treea2a7616111ee43f0b4fb754b464e8087f37c0dcb
parentdev-python/pytest-pep8: Initial commit. (diff)
downloadgentoo-b730a5be0e15eac40a0c0948820ae7bdb7fa780e.tar.gz
gentoo-b730a5be0e15eac40a0c0948820ae7bdb7fa780e.tar.bz2
gentoo-b730a5be0e15eac40a0c0948820ae7bdb7fa780e.zip
dev-python/wstools: Bump to version 0.4.4
Dropped most KEYWORDS because of new dependencies. Package-Manager: portage-2.3.2
-rw-r--r--dev-python/wstools/Manifest1
-rw-r--r--dev-python/wstools/wstools-0.4.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/wstools/Manifest b/dev-python/wstools/Manifest
index 31db4bd0c008..1f470c0510c8 100644
--- a/dev-python/wstools/Manifest
+++ b/dev-python/wstools/Manifest
@@ -1 +1,2 @@
DIST wstools-0.4.3.tar.gz 148878 SHA256 578b53e98bc8dadf5a55dfd1f559fd9b37a594609f1883f23e8646d2d30336f8 SHA512 e735e2ae63aa410a56c79bef0bec7196393bb8f52d8521001d298b6290a75662f7262b6cd3c3238eeaf33263036cc6dabf8435ebd2fd1c98481cea524d0382ed WHIRLPOOL fa5ca24db23d99337cb08f3317327f6076f230c787477275e54d2322931d4e86831357043df6e8c12f3a62bac95eda13f614120588e9d3265ba40251c68b2881
+DIST wstools-0.4.4.tar.gz 53813 SHA256 000cca12538e30547d4655ce84ef4977dabfc65a7b27d28e319695b78aa40126 SHA512 a9a31f3e31ab4d06d7ad151a5df4a710fecba7cf5da533b0f7b84fe7c1c49d4837dd8304cbbe17080d621521fe90ebe78a571d6e76dba8ca75e84b6e391ab1ce WHIRLPOOL 8dad867b613b821126e8068fc49fb5cabc6ace52344dac24c2869169d954e0cf42c7ded1e31900d585d1f83d5c8e187b5c5f0ae5a1a899e60ff55aa575571151
diff --git a/dev-python/wstools/wstools-0.4.4.ebuild b/dev-python/wstools/wstools-0.4.4.ebuild
new file mode 100644
index 000000000000..74ce4956adb1
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools https://pypi.python.org/pypi/wstools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"