summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-04 14:56:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-04 14:56:52 +0200
commitb730bdddde73e0621e1f96e756778ab79fb729d7 (patch)
tree993fa8fb63cbf0f9525feec0bf66ff6889280e5f
parentdev-python/aiohttp-socks: Bump to 0.8.1 (diff)
downloadgentoo-b730bdddde73e0621e1f96e756778ab79fb729d7.tar.gz
gentoo-b730bdddde73e0621e1f96e756778ab79fb729d7.tar.bz2
gentoo-b730bdddde73e0621e1f96e756778ab79fb729d7.zip
dev-python/imageio: Bump to 2.31.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.31.3.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 4cdd3a685e96..5e17ad9b50bb 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1,4 +1,5 @@
DIST imageio-2.31.1.gh.tar.gz 411419 BLAKE2B 4167e073daeb4a05cc88cfca78764468d33cb7d3d0ae8a75f43bb40312b44c1e5b0cd1416203addb853a8ada744ff97bdec3dc42685d6aec0ee8e4be839d8490 SHA512 8fa322816ddc041bb84a0b6ac9282fffdfb3894f3594e36c554cec9ae8d0898a7b005b9d43e7b4065fc6ca71301b63e95e46cb0a73ebedbd9004bca0146b535d
DIST imageio-2.31.2.gh.tar.gz 411570 BLAKE2B bf2b92e7d9875ed6285c33ef04baa8b6bb798210bd0c1efcaf81f23a75641964dbd8f9139690928bbecbeae15cc9a7df63898e497b2234b3999dbe91c9b20d78 SHA512 9aff670c10a1cc67c3d71bea6014e5d5bb3da7a63037056f077266005bdc72ec39fcc6afdc5c130753019b00f7306963f133cbf663a3b59490401353e21f74bc
+DIST imageio-2.31.3.gh.tar.gz 411838 BLAKE2B 923a21a211150d2356a2484b6c90dc9c210791c6978457bab54182d9d2ee7557d1935d1550439cd23c2b94b3280fdbed2b7561724784d2d8d331c349ae2c0b21 SHA512 9027cf171e2a0a6137c2b8b28ef864effaea230fce2cadabded12f95a57e627b86e715d8ca3ba7eb02c8d88aa237f0097232d5d8d7b3d4742cf8d35995704c5b
DIST imageio-chelsea.png 221294 BLAKE2B 58537d7a1678fa5be4cc899e5bacd925bfc180eb4ae691330a53749a49ff544e979609b529ed27e5c1fc9efe4bc050ca1ce49b777f4016fb1d66affd926ef9d3 SHA512 48470cdb843eed4dfa6673811c09c5aac9869ee23dd36be0c6b653d9f108d61d21b148c2a4435aaa6604887ba030e5bbc5e35d378da876366445dfc2d0ba4e27
DIST imageio-cockatoo.mp4 728751 BLAKE2B 45b22cd517c1cb7c0cd12f8865facaca6a847047aea716e49633cf2b1dc13826f94787c8a8f9dd5f48c6a896f5d37794c0058da1bde9e1469f196916476dbfa2 SHA512 e9cb7c25de8019c59ba4090cf10ab29f2b5d62ada37a877081ca07d2ecfe010036222ae843b41bbcc843130d97fa5e14421de252639e9481df1d1c27b19add49
diff --git a/dev-python/imageio/imageio-2.31.3.ebuild b/dev-python/imageio/imageio-2.31.3.ebuild
new file mode 100644
index 000000000000..07ef8bc8f8b1
--- /dev/null
+++ b/dev-python/imageio/imageio-2.31.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+BIN_COMMIT=224074bca448815e421a59266864c23041531a42
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="
+ https://imageio.readthedocs.io/en/stable/
+ https://github.com/imageio/imageio/
+ https://pypi.org/project/imageio/
+"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/chelsea.png
+ -> ${PN}-chelsea.png
+ https://github.com/imageio/imageio-binaries/raw/${BIN_COMMIT}/images/cockatoo.mp4
+ -> ${PN}-cockatoo.mp4
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# over 50% of tests rely on Internet
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+# requests for fsspec[github]
+BDEPEND="
+ test? (
+ dev-python/fsspec[${PYTHON_USEDEP}]
+ dev-python/imageio-ffmpeg[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ # block silently downloading vulnerable libraries from the Internet
+ "${FILESDIR}"/imageio-2.22.0-block-download.patch
+ )
+
+ if use test; then
+ mkdir -p "${HOME}"/.imageio/images || die
+ local i
+ for i in chelsea.png cockatoo.mp4; do
+ cp "${DISTDIR}/${PN}-${i}" "${HOME}/.imageio/images/${i}" || die
+ done
+ fi
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+ # Tries to download ffmpeg binary ?!
+ tests/test_ffmpeg.py::test_get_exe_installed
+ # blocked by our patch
+ tests/test_core.py::test_fetching
+ tests/test_core.py::test_request
+ # known broken
+ # https://github.com/imageio/imageio/issues/890
+ tests/test_freeimage.py::test_exr_write
+)