summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-25 07:16:22 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-25 07:16:22 +0200
commitb7653a4d9d96721fd89d36bb7613f242d266967a (patch)
treeafd56d0fa856666e1ff114f8a0aedd9510549cda
parentdev-ruby/net-ssh: require slot 4 of rbnacl (diff)
downloadgentoo-b7653a4d9d96721fd89d36bb7613f242d266967a.tar.gz
gentoo-b7653a4d9d96721fd89d36bb7613f242d266967a.tar.bz2
gentoo-b7653a4d9d96721fd89d36bb7613f242d266967a.zip
dev-ruby/parallel: cleanup
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ruby/parallel/Manifest2
-rw-r--r--dev-ruby/parallel/parallel-1.10.0.ebuild51
-rw-r--r--dev-ruby/parallel/parallel-1.11.1.ebuild51
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-ruby/parallel/Manifest b/dev-ruby/parallel/Manifest
index 70c46a4d76f4..433a850a4908 100644
--- a/dev-ruby/parallel/Manifest
+++ b/dev-ruby/parallel/Manifest
@@ -1,3 +1 @@
-DIST parallel-1.10.0.tar.gz 19237 SHA256 33ff9a87879a8e5d1f69778ecb10b7d2b9ba4e28c464c0f55486935e553da552 SHA512 03a61c6fc00bcaf054ccaf74257a2249ecb8b471e070f6c174f3f26ced4b939bcefb0b6b18eaba4d71e4c04f1e0b32ee857a936ebef9d3b7ed9aad1d758c40db WHIRLPOOL 3f01bb6e21df986819cab4286c319e6b83eb6c7a7e74e9e06aa3137b499ca3e863180de7c2eac1e6072f59f8628e99a73799abd605425917e16be2ff149762f6
-DIST parallel-1.11.1.tar.gz 20389 SHA256 78a27f40e548d92bd1aa7d8efd7c5622f9eb6c67102a5d43c45a6fcd8a04a3c3 SHA512 b7ef113342f2469f5555896757ce8b19de50f202697c29b767742a6c0bd88c2694d945e49e510c4fab0d219959c9d62c60826a0daa9520f89c1de3da14c275ba WHIRLPOOL 9ad7c54e049d1c97909d0be2ab453675dbc69d43c65e8712bde745391e4d57436548cad4c772c51dc26f6b5b55f8c0aca7c50665eb3d2a79a476b315231e17de
DIST parallel-1.11.2.tar.gz 20403 SHA256 cc8d3916f66b3bfd1acf87d27ee47fb7dcf71efe3551186d97ca79dea9ce3fce SHA512 4763abeb76ba50000eb88c85f661a794d784e457ed7ba6bd1367e65d802006bfd05cad017fb9a8fa3ca45ee87bb54c2dda218099fe78b2f6f36b05632d2ccd3d WHIRLPOOL 2d1864f9dc4bce5378355668a1fe287832891945958dfcce3856f25e134e1681af9d91fa6cd2774816c0315b371677b6c9f7a7d8e9fb33666ad8bf891c9b35e6
diff --git a/dev-ruby/parallel/parallel-1.10.0.ebuild b/dev-ruby/parallel/parallel-1.10.0.ebuild
deleted file mode 100644
index fb6b05d0a0e7..000000000000
--- a/dev-ruby/parallel/parallel-1.10.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:4.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>4.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}
diff --git a/dev-ruby/parallel/parallel-1.11.1.ebuild b/dev-ruby/parallel/parallel-1.11.1.ebuild
deleted file mode 100644
index fb6b05d0a0e7..000000000000
--- a/dev-ruby/parallel/parallel-1.11.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:4.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>4.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}