summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-16 11:27:14 +0100
committerSam James <sam@gentoo.org>2023-04-17 00:16:42 +0100
commitb76590f9fb8615da3da9d783ad841c0e3881a27b (patch)
tree689bde47dce5fa837c7cf637685e7fb711558dba
parentdev-lang/eisl: drop old 2.70 (diff)
downloadgentoo-b76590f9fb8615da3da9d783ad841c0e3881a27b.tar.gz
gentoo-b76590f9fb8615da3da9d783ad841c0e3881a27b.tar.bz2
gentoo-b76590f9fb8615da3da9d783ad841c0e3881a27b.zip
media-libs/opencollada: fix build w/ gcc 13, drop -Werror
Closes: https://bugs.gentoo.org/877335 Closes: https://bugs.gentoo.org/895102 Closes: https://bugs.gentoo.org/899750 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/opencollada/files/opencollada-1.6.68-gcc13.patch35
-rw-r--r--media-libs/opencollada/files/opencollada-1.6.68-werror.patch11
-rw-r--r--media-libs/opencollada/opencollada-1.6.68.ebuild4
3 files changed, 49 insertions, 1 deletions
diff --git a/media-libs/opencollada/files/opencollada-1.6.68-gcc13.patch b/media-libs/opencollada/files/opencollada-1.6.68-gcc13.patch
new file mode 100644
index 000000000000..e12771ca97a4
--- /dev/null
+++ b/media-libs/opencollada/files/opencollada-1.6.68-gcc13.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/899750
+https://github.com/KhronosGroup/OpenCOLLADA/pull/656
+
+From 84c8c9a02b4e5fe40465034563cb36527e865dac Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Mon, 11 Jul 2022 21:33:11 +0100
+Subject: [PATCH] DAEValidator: fix gcc-13 build
+
+On gcc-13 c++ headers don't include <stdint.h> implicitly any more.
+This exposed build failure as:
+
+ /build/source/DAEValidator/library/src/XmlDoc.cpp: In member function 'virtual void opencollada::XmlDoc::readFile(const std::string&)':
+ /build/source/DAEValidator/library/src/XmlDoc.cpp:59:17: error: 'uint32_t' was not declared in this scope
+ 59 | uint32_t signature = *reinterpret_cast<const uint32_t*>(content.data());
+ | ^~~~~~~~
+--- a/DAEValidator/library/src/DaeValidator.cpp
++++ b/DAEValidator/library/src/DaeValidator.cpp
+@@ -4,6 +4,7 @@
+ #include "Strings.h"
+ #include "StringUtil.h"
+ #include <cmath>
++#include <cstdint>
+ #include "no_warning_iomanip"
+ #include "no_warning_iostream"
+ #include <set>
+--- a/DAEValidator/library/src/XmlDoc.cpp
++++ b/DAEValidator/library/src/XmlDoc.cpp
+@@ -1,5 +1,6 @@
+ #include "Macros.h"
+
++#include <cstdint>
+ #if IS_GNUC_AND_GNUC_VERSION_LT(5,1,1)
+ #include <cstring>
+ #endif
+
diff --git a/media-libs/opencollada/files/opencollada-1.6.68-werror.patch b/media-libs/opencollada/files/opencollada-1.6.68-werror.patch
new file mode 100644
index 000000000000..3a490d326ddc
--- /dev/null
+++ b/media-libs/opencollada/files/opencollada-1.6.68-werror.patch
@@ -0,0 +1,11 @@
+--- a/DAEValidator/CMakeLists.txt
++++ b/DAEValidator/CMakeLists.txt
+@@ -100,7 +100,7 @@ if (WIN32)
+ # C4820: 'bytes' bytes padding added after construct 'member_name'
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /MP /Wall /WX /wd4505 /wd4514 /wd4592 /wd4710 /wd4711 /wd4820")
+ else ()
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Werror")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
+ endif ()
+
+ add_custom_command(
diff --git a/media-libs/opencollada/opencollada-1.6.68.ebuild b/media-libs/opencollada/opencollada-1.6.68.ebuild
index 49f53f567c18..d11bbc826b9f 100644
--- a/media-libs/opencollada/opencollada-1.6.68.ebuild
+++ b/media-libs/opencollada/opencollada-1.6.68.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,6 +33,8 @@ PATCHES=(
"${FILESDIR}/${P}-fix-null-conversion.patch"
"${FILESDIR}/${P}-cmake-fixes.patch"
"${FILESDIR}/${PN}-1.6.63-pcre-fix.patch"
+ "${FILESDIR}/${PN}-1.6.68-gcc13.patch"
+ "${FILESDIR}/${PN}-1.6.68-werror.patch"
)
src_prepare() {