summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2018-02-13 15:31:57 -0800
committerPatrice Clement <monsieurp@gentoo.org>2018-03-05 23:07:58 +0100
commitb769bdae5a72fa721fca1968779899601a6875f0 (patch)
tree2eecd926200282b224f14238d6537791ed522f71
parentdev-python/neovim-python-client: fix dependencies. (diff)
downloadgentoo-b769bdae5a72.tar.gz
gentoo-b769bdae5a72.tar.bz2
gentoo-b769bdae5a72.zip
dev-python/neovim-python-client: version bump to 0.2.1.
Depends on #7176
-rw-r--r--dev-python/neovim-python-client/Manifest1
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.2.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/neovim-python-client/Manifest b/dev-python/neovim-python-client/Manifest
index 0b64c9722233..8586cae21064 100644
--- a/dev-python/neovim-python-client/Manifest
+++ b/dev-python/neovim-python-client/Manifest
@@ -1,3 +1,4 @@
DIST neovim-python-client-0.1.13.tar.gz 41413 BLAKE2B 819c3e7763cfb357d45130928dab23ad149a5f9d8efb0df8699a805bc394662447837ad3edc869705a95d74a37f2eec4f155212da918ac779d389c150a0d7189 SHA512 ecef42601632551c98f8de019bfdf4dbff3ce1f0e1b6943b78a506b710e5810f6a7e611adc09435992b97288ff365a416870a74202a5c68236b5daeb51d15c8b
DIST neovim-python-client-0.1.9.tar.gz 40599 BLAKE2B 48b43d344ed0c7aa3faa95a16c9714f2d105a916364db55d68263db7b8307a90d084bcf7559dd17277bb8dfbe6d7bbab8d3dafa250b4825b2cebddc00d130dee SHA512 043429407d140b37004d5344f9244c8cb5a37e2b5d450454e6535bece7fb05f037e5eff2a63431fad55ab2470372c4a17e0a608a94af65a2f400f2158b736ce4
DIST neovim-python-client-0.2.0.tar.gz 41892 BLAKE2B 0ae59548ae1e376c618c24edfa73f3f68f5c059b2772be8ba3aae08d38c7a368d8b341da0221092ec8fb132843e1ea2d313bedf0c51fd202d5953e530f205d3a SHA512 b8363be2892f4dfaed0251186a3f370ec31be51710b659b71f52575da773e254b388afec2f5999a6b526d722b5232a16c59d7e28e49df30b4760ef030238d068
+DIST neovim-python-client-0.2.1.tar.gz 41971 BLAKE2B 9ebff937e08963cb8c764c4dcfcef8b6e28e8d0219635f9602ccc77b0bf4412a797de71fbf149bcaafe85bd1122a0d3cec1d8bfa81217c8c2d5a89bc1772c572 SHA512 710be7f5355077fa1eae256c541a06d475902492a19638c5786e25aafb9181f40afcc8df70aca0da15a569a9d6b095ab7bd8008e4f947725cf081954fb7c042e
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.2.1.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.2.1.ebuild
new file mode 100644
index 000000000000..3814f0211ef1
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/python-client"
+SRC_URI="https://github.com/neovim/python-client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/msgpack-0.5.2[${PYTHON_USEDEP}]
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
+
+RDEPEND="
+ ${DEPEND}
+ >=app-editors/neovim-0.2.1"
+
+S="${WORKDIR}/python-client-${PV}"