summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-28 13:09:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-28 13:37:41 +0200
commitb77363f77096a04f0d92fd7ea1e7f61a02161297 (patch)
tree8e78e760a7789004cefd1a62bdf2d6362c53c2d8
parentdev-ros/class_loader: bump subslot (diff)
downloadgentoo-b77363f7.tar.gz
gentoo-b77363f7.tar.bz2
gentoo-b77363f7.zip
dev-ros/depthimage_to_laserscan: fix build with latest pluginlib
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild4
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild3
-rw-r--r--dev-ros/depthimage_to_laserscan/files/pluginlib.patch11
3 files changed, 15 insertions, 3 deletions
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
index b0b3cce5f4e8..2e621e904b7b 100644
--- a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,4 +25,4 @@ RDEPEND="
dev-libs/console_bridge:=
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/isnan.patch" )
+PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
index 9a1d9908c4d6..2e621e904b7b 100644
--- a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,3 +25,4 @@ RDEPEND="
dev-libs/console_bridge:=
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )
diff --git a/dev-ros/depthimage_to_laserscan/files/pluginlib.patch b/dev-ros/depthimage_to_laserscan/files/pluginlib.patch
new file mode 100644
index 000000000000..a367cd40c5f6
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/files/pluginlib.patch
@@ -0,0 +1,11 @@
+Index: depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScanNodelet.cpp
+===================================================================
+--- depthimage_to_laserscan-1.0.7.orig/src/DepthImageToLaserScanNodelet.cpp
++++ depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScanNodelet.cpp
+@@ -57,5 +57,5 @@ private:
+ }
+
+ #include <pluginlib/class_list_macros.h>
+-PLUGINLIB_DECLARE_CLASS(depthimage_to_laserscan, DepthImageToLaserScanNodelet, depthimage_to_laserscan::DepthImageToLaserScanNodelet, nodelet::Nodelet);
++PLUGINLIB_EXPORT_CLASS(depthimage_to_laserscan::DepthImageToLaserScanNodelet, nodelet::Nodelet)
+