summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-17 21:42:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-17 21:42:34 +0200
commitb7849c6062121e8957c1c2fb8f04ae7eac188cc5 (patch)
tree8c2151870108a07934eb97eff04c882e799fc866
parentprofiles: Drop masks for removed man-pages* packages. (diff)
downloadgentoo-b7849c6062121e8957c1c2fb8f04ae7eac188cc5.tar.gz
gentoo-b7849c6062121e8957c1c2fb8f04ae7eac188cc5.tar.bz2
gentoo-b7849c6062121e8957c1c2fb8f04ae7eac188cc5.zip
dev-python/matplotlib-python2: Revert "Remove old"
Restore the stable candidate. Reverts: e400aea7cb14f01602bb4777f407a4df84257664 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/matplotlib-python2/Manifest1
-rw-r--r--dev-python/matplotlib-python2/matplotlib-python2-2.2.4.ebuild216
2 files changed, 217 insertions, 0 deletions
diff --git a/dev-python/matplotlib-python2/Manifest b/dev-python/matplotlib-python2/Manifest
index e15d4fa58675..913bdedd4097 100644
--- a/dev-python/matplotlib-python2/Manifest
+++ b/dev-python/matplotlib-python2/Manifest
@@ -1 +1,2 @@
+DIST matplotlib-2.2.4.tar.gz 36974286 BLAKE2B 9c4c69163a23ff02107ee155f72e142dcf31ba965f6a20f468b96f3f4b70b95ff6caade6b14bcbacd5b231848d2000ce6af9f113feefb41d6e186725349490d3 SHA512 968f5731b8a9a2c5575403c60d5b0a98a452b33094e520be44f4d901f892d082babc8fc1d73c519e1ff2baf756f3cb7652f4b796e166d66dfda31f7e50c58139
DIST matplotlib-2.2.5.tar.gz 36678633 BLAKE2B fb3084a2d34a920413c44a23a956ffdcf7a31d521e2d1df50a68c9f17882cb87deebb403ec47154284593b39df24dad72e6352e1427091f795058db11f1d3a1b SHA512 f4771dca4b3c936e0d47f42630759207ccfe11586b3efadb401144b014a600914a6521af4fbe060fa80fd74132c92f1d3b37cac4fea9999ca90300c1dec8391b
diff --git a/dev-python/matplotlib-python2/matplotlib-python2-2.2.4.ebuild b/dev-python/matplotlib-python2/matplotlib-python2-2.2.4.ebuild
new file mode 100644
index 000000000000..3f9831ca74f1
--- /dev/null
+++ b/dev-python/matplotlib-python2/matplotlib-python2-2.2.4.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
+
+MY_PN=${PN/-python2}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Pure python plotting library with matlab like syntax (py2 version)"
+HOMEPAGE="https://matplotlib.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+# Main license: matplotlib
+# Some modules: BSD
+# matplotlib/backends/qt4_editor: MIT
+# Fonts: BitstreamVera, OFL-1.1
+LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="cairo excel gtk2 gtk3 latex qt5 test tk wxwidgets"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ test? (
+ cairo latex qt5 tk wxwidgets
+ || ( gtk2 gtk3 )
+ )"
+
+# #456704 -- a lot of py2-only deps
+COMMON_DEPEND="
+ dev-python/functools32[${PYTHON_USEDEP}]
+ dev-python/subprocess32[${PYTHON_USEDEP}]
+ dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+ dev-python/cycler[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/numpy-python2-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ )
+ dev-python/python-dateutil:0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+ media-fonts/stix-fonts
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=media-libs/qhull-2013
+ >=dev-python/kiwisolver-1.0.0[${PYTHON_USEDEP}]
+ cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
+ gtk2? (
+ dev-libs/glib:2=
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ dev-python/pygtk[${PYTHON_USEDEP}] )
+ wxwidgets? ( >=dev-python/wxpython-2.8:*[${PYTHON_USEDEP}] )"
+
+# internal copy of pycxx highly patched
+# dev-python/pycxx
+
+DEPEND="${COMMON_DEPEND}
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ !<dev-python/matplotlib-3
+ >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
+ excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
+ gtk3? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection] )
+ latex? (
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ app-text/dvipng
+ app-text/poppler[utils]
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-xetex
+ )
+ qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )"
+
+# A few C++ source files are written to srcdir.
+# Other than that, the ebuild shall be fit for out-of-source build.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+pkg_setup() {
+ unset DISPLAY # bug #278524
+}
+
+use_setup() {
+ local uword="${2:-${1}}"
+ if use ${1}; then
+ echo "${uword} = True"
+ echo "${uword}agg = True"
+ else
+ echo "${uword} = False"
+ echo "${uword}agg = False"
+ fi
+}
+
+python_prepare_all() {
+# Generates test failures, but fedora does it
+# local PATCHES=(
+# "${FILESDIR}"/${P}-unbundle-pycxx.patch
+# "${FILESDIR}"/${P}-unbundle-agg.patch
+# )
+# rm -r agg24 CXX || die
+# rm -r agg24 || die
+
+# cat > lib/${PN}/externals/six.py <<-EOF
+# from __future__ import absolute_import
+# from six import *
+# EOF
+
+ local PATCHES=(
+ "${FILESDIR}"/${MY_PN}-2.2.4-doc-fix.patch
+ "${FILESDIR}"/${MY_PN}-2.2.4-no-jqueryui-download.patch
+ )
+
+ sed \
+ -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
+ -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
+ || die "sed pyparsing failed"
+
+ hprefixify setupext.py
+
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+ append-cppflags -DNDEBUG # or get old trying to do triangulation
+ tc-export PKG_CONFIG
+}
+
+python_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+
+ # create setup.cfg (see setup.cfg.template for any changes).
+
+ # common switches.
+ cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
+ [directories]
+ basedirlist = ${EPREFIX}/usr
+ [provide_packages]
+ pytz = False
+ dateutil = False
+ [packages]
+ tests = $(usex test True False)
+ [gui_support]
+ agg = True
+ pyside = False
+ pysideagg = False
+ qt4 = False
+ qt4agg = False
+ $(use_setup cairo)
+ $(use_setup gtk3)
+ $(use_setup qt5)
+ $(use_setup tk)
+ EOF
+
+ if use gtk3 && use cairo; then
+ echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
+ else
+ echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
+ fi
+
+ cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
+ $(use_setup gtk2 gtk)
+ $(use_setup wxwidgets wx)
+ EOF
+}
+
+wrap_setup() {
+ local MAKEOPTS=-j1
+ local -x MPLSETUPCFG="${BUILD_DIR}"/setup.cfg
+ unset DISPLAY
+ "$@"
+}
+
+python_compile() {
+ wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
+}
+
+python_test() {
+ wrap_setup distutils_install_for_testing
+
+ virtx "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)"
+}
+
+python_install() {
+ wrap_setup distutils-r1_python_install
+
+ # mpl_toolkits namespace
+ python_moduleinto mpl_toolkits
+ python_domodule lib/mpl_toolkits/__init__.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}