summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 13:32:20 +0100
committerSam James <sam@gentoo.org>2022-09-09 13:34:12 +0100
commitb7a6f1a26fae20fe511f05ac09702ed3c94da6fb (patch)
tree6a065e72e3f2794a886635914586dc571a468320
parentgames-emulation/mupen64plus-core: Backport crash fix (diff)
downloadgentoo-b7a6f1a2.tar.gz
gentoo-b7a6f1a2.tar.bz2
gentoo-b7a6f1a2.zip
sys-libs/ncurses: use hosted patchset for 6.3_p20220903
This is needed because we really want the full generated configure files in addition to the source (configure.in changes). It's far too hard to rebase and also ensure the patches are doing what they're supposed to if just relying on patches to a huge configure script. Rebase the whole lot, and then throw in the patch for bug 869128 from 345696eea0fbeb96946f1c1ae7293150c2c7e8ad. Closes: https://bugs.gentoo.org/869128 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/ncurses/Manifest2
-rw-r--r--sys-libs/ncurses/ncurses-6.3_p20220903-r1.ebuild44
-rw-r--r--sys-libs/ncurses/ncurses-6.3_p20220903.ebuild46
3 files changed, 50 insertions, 42 deletions
diff --git a/sys-libs/ncurses/Manifest b/sys-libs/ncurses/Manifest
index 6f1cdb953a38..526a2fe5fe91 100644
--- a/sys-libs/ncurses/Manifest
+++ b/sys-libs/ncurses/Manifest
@@ -94,4 +94,4 @@ DIST ncurses-6.3-20220903.patch.gz 4814 BLAKE2B 668041aef48d9ce37474edc6d70e0725
DIST ncurses-6.3-20220903.patch.gz.asc 729 BLAKE2B 2f076ce9d390ee02edc0b58ecf3a6881897062e34a5f4c09b503c4b306ee70fb0f08e38518029eae4933508a48bda92716dd4b76159a0aa3d7bbd3835d2695ff SHA512 18cb1a77f67b6fddc9f83366487cb547fe1439e7edcd4fc27632702cd3ffc79622dd1421d32454489d08acec7403a04239b34794e81750b703385189a4534b04
DIST ncurses-6.3.tar.gz 3583550 BLAKE2B b2c174ac48d587b4d3aa054f04e4ec8bffd8a657a4aff5f090104965c741901e600712c8f8e5e98f3b8a26bc558996a1e14a746f113854832853b855e9d406c3 SHA512 5373f228cba6b7869210384a607a2d7faecfcbfef6dbfcd7c513f4e84fbd8bcad53ac7db2e7e84b95582248c1039dcfc7c4db205a618f7da22a166db482f0105
DIST ncurses-6.3.tar.gz.sig 438 BLAKE2B d7f9852292110fe7a048a9e38611ea06564b5142cb4cbeb8d99bba752d5df8eeffa3b57e5ca315c14024520bc008b30650e99669c995dca05a798399a0c85d39 SHA512 b9a2a25e0b1854c272bf89c610c81fc0ba061f0296eca5c0079a79cfe310e44eb16c46eb5a0dd018f1ca9114d569c9d5087a2b8e60b0344f1eb97f7c5addafc6
-DIST ncurses-6.3_p20220903-musl-xopen_source.patch.xz 43008 BLAKE2B 463645c62d2c72e8e1be14e510867d709ec6f78e3d7b78df317f5a8351264f19c04cb93cd3296a1df783db58d4ed5e5885f9b45a04dd0d549db9e41274d8448f SHA512 c2b0810fafca1cffb27095d207fe2d29daf5d1bbc79142a717ea79df8d3873b12664fbd8538e08c4576f9366acc7ac335b56df62310efc191cf20df52af2bf1c
+DIST ncurses-6.3_p20220903-patches.tar.xz 76908 BLAKE2B a5afb3a5c016ad6b602e6af77cc4fc067692f1e1245cf006feb2b74e69be13b2ffb2b14c7b5de48780965d6b596621cc399c316657ae63afbe5ea9ff2d9715fa SHA512 11ae7458f925a68bf6d482f204e9e57ef23cf456ea9827c713787f635bd11621c3612651a90f3f3a3c7c2742f95fde4bc87d6500115ef74300b9a4d240ff74ad
diff --git a/sys-libs/ncurses/ncurses-6.3_p20220903-r1.ebuild b/sys-libs/ncurses/ncurses-6.3_p20220903-r1.ebuild
index d2f153326cad..c8f854c99411 100644
--- a/sys-libs/ncurses/ncurses-6.3_p20220903-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-6.3_p20220903-r1.ebuild
@@ -103,7 +103,7 @@ if [[ ${PV} == *_p* ]] ; then
unset my_patch_index
fi
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-6.3_p20220903-musl-xopen_source.patch.xz"
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-6.3_p20220903-patches.tar.xz"
fi
LICENSE="MIT"
@@ -125,28 +125,32 @@ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-thomasdickey )"
S="${WORKDIR}/${MY_P}"
PATCHES=(
- ${UPSTREAM_PATCHES[@]}
-
- "${FILESDIR}/${PN}-5.7-nongnu.patch"
- "${FILESDIR}/${PN}-6.0-rxvt-unicode-9.15.patch" # bug #192083, bug #383871
- "${FILESDIR}/${PN}-6.0-pkg-config.patch"
- "${FILESDIR}/${PN}-6.0-ticlib.patch" # bug #557360
- "${FILESDIR}/${PN}-6.2_p20210123-cppflags-cross.patch" # bug #601426
- "${WORKDIR}/${PN}-6.3_p20220903-musl-xopen_source.patch" # bug #869128
+ "${UPSTREAM_PATCHES[@]}"
+
+ # When rebasing Gentoo's patchset, please use git from a clean
+ # src_unpack with upstream patches already applied. git am
+ # the existing patchset and rebase as required. This makes it easier
+ # to manage future rebasing & adding new patches.
+ #
+ # For the same reasons, please include the original configure.in changes,
+ # NOT just the generated results!
+ "${WORKDIR}"/${PN}-6.3_p20220903-patches
)
src_unpack() {
- # Can drop this implementation once 6.3_p20220903-musl-xopen_source.patch is dropped
- local file
- for file in ${A} ; do
- if [[ ${file} == ${MY_P}.tar.gz ]] ; then
- verify-sig_verify_detached "${DISTDIR}"/${file} "${DISTDIR}"/${file}.sig
- else
- [[ ${file} == @(*musl-xopen_source.patch.xz|*.asc|*.sig) ]] && continue
-
- verify-sig_verify_detached "${DISTDIR}"/${file} "${DISTDIR}"/${file}.asc
- fi
- done
+ # Avoid trying to verify our own patchset tarball, there's no point
+ if use verify-sig ; then
+ local file
+ for file in ${A} ; do
+ if [[ ${file} == ${MY_P}.tar.gz ]] ; then
+ verify-sig_verify_detached "${DISTDIR}"/${file} "${DISTDIR}"/${file}.sig
+ else
+ [[ ${file} == @(patches.tar.xz|*.asc|*.sig) ]] && continue
+
+ verify-sig_verify_detached "${DISTDIR}"/${file} "${DISTDIR}"/${file}.asc
+ fi
+ done
+ fi
default
}
diff --git a/sys-libs/ncurses/ncurses-6.3_p20220903.ebuild b/sys-libs/ncurses/ncurses-6.3_p20220903.ebuild
index dc99aab55fc5..389f5c864ed5 100644
--- a/sys-libs/ncurses/ncurses-6.3_p20220903.ebuild
+++ b/sys-libs/ncurses/ncurses-6.3_p20220903.ebuild
@@ -103,13 +103,13 @@ if [[ ${PV} == *_p* ]] ; then
unset my_patch_index
fi
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-6.3_p20220903-musl-xopen_source.patch.xz"
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-6.3_p20220903-patches.tar.xz"
fi
LICENSE="MIT"
# The subslot reflects the SONAME.
SLOT="0/6"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="ada +cxx debug doc gpm minimal profile +stack-realign static-libs test tinfo trace"
RESTRICT="!test? ( test )"
@@ -125,28 +125,32 @@ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-thomasdickey )"
S="${WORKDIR}/${MY_P}"
PATCHES=(
- ${UPSTREAM_PATCHES[@]}
-
- "${FILESDIR}/${PN}-5.7-nongnu.patch"
- "${FILESDIR}/${PN}-6.0-rxvt-unicode-9.15.patch" # bug #192083, bug #383871
- "${FILESDIR}/${PN}-6.0-pkg-config.patch"
- "${FILESDIR}/${PN}-6.0-ticlib.patch" # bug #557360
- "${FILESDIR}/${PN}-6.2_p20210123-cppflags-cross.patch" # bug #601426
- "${WORKDIR}/${PN}-6.3_p20220903-musl-xopen_source.patch" # bug #869128
+ "${UPSTREAM_PATCHES[@]}"
+
+ # When rebasing Gentoo's patchset, please use git from a clean
+ # src_unpack with upstream patches already applied. git am
+ # the existing patchset and rebase as required. This makes it easier
+ # to manage future rebasing & adding new patches.
+ #
+ # For the same reasons, please include the original configure.in changes,
+ # NOT just the generated results!
+ "${WORKDIR}"/${PN}-6.3_p20220903-patches
)
src_unpack() {
- # Can drop this implementation once 6.3_p20220903-musl-xopen_source.patch is dropped
- local file
- for file in ${A} ; do
- if [[ ${file} == ${MY_P}.tar.gz ]] ; then
- verify-sig_verify_detached "${DISTDIR}"/${file} "${DISTDIR}"/${file}.sig
- else
- [[ ${file} == @(*musl-xopen_source.patch.xz|*.asc|*.sig) ]] && continue
-
- verify-sig_verify_detached "${DISTDIR}"/${file} "${DISTDIR}"/${file}.asc
- fi
- done
+ # Avoid trying to verify our own patchset tarball, there's no point
+ if use verify-sig ; then
+ local file
+ for file in ${A} ; do
+ if [[ ${file} == ${MY_P}.tar.gz ]] ; then
+ verify-sig_verify_detached "${DISTDIR}"/${file} "${DISTDIR}"/${file}.sig
+ else
+ [[ ${file} == @(patches.tar.xz|*.asc|*.sig) ]] && continue
+
+ verify-sig_verify_detached "${DISTDIR}"/${file} "${DISTDIR}"/${file}.asc
+ fi
+ done
+ fi
default
}