summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-17 23:51:39 +0000
committerSam James <sam@gentoo.org>2022-07-18 00:26:09 +0000
commitb7b9c245afbc71a60149bcaf4f57852aeb9400bc (patch)
tree41b600640df856548dc434e9b61c68daa9a75d77
parentdev-python/adblock: add 0.6.0 (diff)
downloadgentoo-b7b9c245afbc71a60149bcaf4f57852aeb9400bc.tar.gz
gentoo-b7b9c245afbc71a60149bcaf4f57852aeb9400bc.tar.bz2
gentoo-b7b9c245afbc71a60149bcaf4f57852aeb9400bc.zip
app-text/cherrytree: add 0.99.48
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/cherrytree/Manifest1
-rw-r--r--app-text/cherrytree/cherrytree-0.99.48.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-text/cherrytree/Manifest b/app-text/cherrytree/Manifest
index b18ed8916d6a..8337beb3344f 100644
--- a/app-text/cherrytree/Manifest
+++ b/app-text/cherrytree/Manifest
@@ -1,2 +1,3 @@
DIST cherrytree-0.99.37.tar.gz 17983743 BLAKE2B 42e5464f4cba4364dbbdabe5daaf80517a62f3f4b2c1c3efa764e9b10dfae492bf335403d24a7a33d9b7c8cd55a0c55ad359ffca1f639fa7622e00a416defd60 SHA512 2413924d03c65dfad820bc2b1e345b7dd74b69d11a10ee0d333400936eb31368f53f2aee77a3dd708adb3d4b91578c0499766bca4c85537822e9c4b3d41c6800
DIST cherrytree_0.99.47.tar.xz 2457904 BLAKE2B 1072de8ed62757a873a258dc9ab1e9e186128b520e7f02e0a2cd8e7e0173232af7db85e3293efd21b577e51b6f5e55cca0cf35631e34279e32dc07836335b742 SHA512 2611be4c24a188793aa6785d96b33ec91c0957b30616352e1cb2cd12f296e39c29666d37a03016be6c934898bf6deb98af74c2c345d9c70f138f62ac6b10f023
+DIST cherrytree_0.99.48.tar.xz 3474468 BLAKE2B b60cc2ffa4f5bd6e91e2a8b34811ad6977d46bdd02c7c1b2bfcdbf4df6107753a2390bc6a15daae8d5268af017ff52d217ab79ed5b4d5d107ef736257999b865 SHA512 eb4690bbc5865b9a0c7d0cb11341fe5ac17f11d417ad765b29784083a83f18c06a39b5b738838e3d57754de25adf1861ea4a6ad472e01a895e8fce0af0964926
diff --git a/app-text/cherrytree/cherrytree-0.99.48.ebuild b/app-text/cherrytree/cherrytree-0.99.48.ebuild
new file mode 100644
index 000000000000..7787d4048a92
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.99.48.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-any-r1 xdg
+
+DESCRIPTION="A hierarchical note taking application (C++ version)"
+HOMEPAGE="https://www.giuspen.com/cherrytree https://github.com/giuspen/cherrytree"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/giuspen/cherrytree"
+ S="${WORKDIR}/${P}/future"
+else
+ SRC_URI="https://github.com/giuspen/cherrytree/releases/download/${PV}/${P/-/_}.tar.xz"
+ #SRC_URI="https://github.com/giuspen/cherrytree/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P/-/_}
+
+ KEYWORDS="~amd64 ~x86"
+ # S="${WORKDIR}/${PN}-${COMMIT}/future"
+fi
+
+# GPL-3 — future/src/ct (CherryTree)
+# LGPL-2.1 — future/src/7za (7zip)
+# MIT — future/src/fmt (libfmt)
+LICENSE="GPL-3 LGPL-2.1 MIT"
+SLOT="0"
+IUSE="nls test"
+
+# Has deps that aren't available in ::gentoo repo
+RESTRICT="test"
+
+RDEPEND="app-i18n/uchardet
+ app-text/gspell:=
+ >=dev-cpp/glibmm-2.64.2:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/gtksourceviewmm:3.0
+ dev-cpp/libxmlpp:2.6
+ dev-cpp/pangomm:1.4
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/libxml2:2
+ dev-libs/fribidi
+ dev-libs/spdlog
+ net-misc/curl
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ $(python_gen_any_dep 'dev-python/lxml[${PYTHON_USEDEP}]')"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+ nls? (
+ sys-devel/gettext
+ )
+ test? ( dev-util/cpputest )"
+
+python_check_deps() {
+ has_version "dev-python/lxml[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ # disable compress man pages
+ sed -i -e \
+ '/install(FILES/s|${MANFILE_FULL_GZ}|${CMAKE_SOURCE_DIR}/data/cherrytree.1|' \
+ CMakeLists.txt || die
+
+ if [[ ${PV} != *9999 ]]; then
+ sed -i \
+ -e "/^set(CT_VERSION/s|\"\(.*\)\"|\"${PV}\"|" \
+ CMakeLists.txt || die
+ fi
+
+ # python_fix_shebang .
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_EXEC="${PYTHON}"
+ -DUSE_NLS=$(usex nls)
+ -DBUILD_TESTING=$(usex test)
+ -DUSE_SHARED_FMT_SPDLOG=ON
+ )
+
+ cmake_src_configure
+}