summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-12 02:31:52 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-12 07:59:29 -0400
commitb7c035bb29c08a6d848d1c11d1b3ec154bcc3506 (patch)
treeaeca0c934017c8573510cb8862d9a7139b706605
parentdev-qt/qttools: disable unity build with USE=designer (diff)
downloadgentoo-b7c035bb29c08a6d848d1c11d1b3ec154bcc3506.tar.gz
gentoo-b7c035bb29c08a6d848d1c11d1b3ec154bcc3506.tar.bz2
gentoo-b7c035bb29c08a6d848d1c11d1b3ec154bcc3506.zip
dev-qt/qt3d: disable unity build (qt6)
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qt3d/qt3d-6.6.9999.ebuild3
-rw-r--r--dev-qt/qt3d/qt3d-6.7.9999.ebuild3
-rw-r--r--dev-qt/qt3d/qt3d-6.9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/dev-qt/qt3d/qt3d-6.6.9999.ebuild b/dev-qt/qt3d/qt3d-6.6.9999.ebuild
index fac726abc29b..cfb594779d2b 100644
--- a/dev-qt/qt3d/qt3d-6.6.9999.ebuild
+++ b/dev-qt/qt3d/qt3d-6.6.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,7 @@ src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Qml)
-DQT_FEATURE_qt3d_system_assimp=ON
+ -DQT_UNITY_BUILD=OFF # fails to build
)
qt6-build_src_configure
diff --git a/dev-qt/qt3d/qt3d-6.7.9999.ebuild b/dev-qt/qt3d/qt3d-6.7.9999.ebuild
index fac726abc29b..cfb594779d2b 100644
--- a/dev-qt/qt3d/qt3d-6.7.9999.ebuild
+++ b/dev-qt/qt3d/qt3d-6.7.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,7 @@ src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Qml)
-DQT_FEATURE_qt3d_system_assimp=ON
+ -DQT_UNITY_BUILD=OFF # fails to build
)
qt6-build_src_configure
diff --git a/dev-qt/qt3d/qt3d-6.9999.ebuild b/dev-qt/qt3d/qt3d-6.9999.ebuild
index fac726abc29b..cfb594779d2b 100644
--- a/dev-qt/qt3d/qt3d-6.9999.ebuild
+++ b/dev-qt/qt3d/qt3d-6.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,7 @@ src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Qml)
-DQT_FEATURE_qt3d_system_assimp=ON
+ -DQT_UNITY_BUILD=OFF # fails to build
)
qt6-build_src_configure