summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-27 00:18:11 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-27 00:53:11 +0200
commitb7c546d8d87c81081b2b90cee5dc651e1710c8e4 (patch)
treea8a9201460cc6c82d0fb9a6bf167cccc15fd1c78
parentnet-proxy/hatop: [QA] Add missing python metadata variables (diff)
downloadgentoo-b7c546d8.tar.gz
gentoo-b7c546d8.tar.bz2
gentoo-b7c546d8.zip
sys-cluster/hpx: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--sys-cluster/hpx/hpx-0.9.10.ebuild10
-rw-r--r--sys-cluster/hpx/hpx-0.9.8.ebuild9
-rw-r--r--sys-cluster/hpx/hpx-0.9.9.ebuild10
-rw-r--r--sys-cluster/hpx/hpx-0.9.99.ebuild8
-rw-r--r--sys-cluster/hpx/hpx-1.0.0.ebuild6
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild8
6 files changed, 25 insertions, 26 deletions
diff --git a/sys-cluster/hpx/hpx-0.9.10.ebuild b/sys-cluster/hpx/hpx-0.9.10.ebuild
index c0535a43f491..3d785033e606 100644
--- a/sys-cluster/hpx/hpx-0.9.10.ebuild
+++ b/sys-cluster/hpx/hpx-0.9.10.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python{2_7,3_4} )
-inherit cmake-utils fortran-2 multilib python-single-r1 versionator
+inherit cmake-utils fortran-2 multilib python-any-r1 versionator
SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -29,17 +29,17 @@ RDEPEND="
"
DEPEND="${RDEPEND}
virtual/pkgconfig
- test? ( dev-lang/python )
+ test? ( ${PYTHON_DEPS} )
doc? ( >=dev-libs/boost-1.56.0-r1[tools] )
"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
jemalloc? ( !perftools !tbb )
perftools? ( !jemalloc !tbb )
tbb? ( !jemalloc !perftools )
"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {
diff --git a/sys-cluster/hpx/hpx-0.9.8.ebuild b/sys-cluster/hpx/hpx-0.9.8.ebuild
index 6f73d465e84e..7694c32d0565 100644
--- a/sys-cluster/hpx/hpx-0.9.8.ebuild
+++ b/sys-cluster/hpx/hpx-0.9.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -9,7 +9,7 @@ SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.7z"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}_${PV}"
-inherit cmake-utils fortran-2 multilib python-single-r1
+inherit cmake-utils fortran-2 multilib python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
@@ -34,9 +34,8 @@ RDEPEND="
DEPEND="${RDEPEND}
app-arch/p7zip
virtual/pkgconfig
- test? ( dev-lang/python )
+ test? ( ${PYTHON_DEPS} )
"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
PATCHES=(
"${FILESDIR}"/hpx-0.9.8-install-path.patch
@@ -45,7 +44,7 @@ PATCHES=(
)
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {
diff --git a/sys-cluster/hpx/hpx-0.9.9.ebuild b/sys-cluster/hpx/hpx-0.9.9.ebuild
index d9b7d1a8e4a0..8001280e7023 100644
--- a/sys-cluster/hpx/hpx-0.9.9.ebuild
+++ b/sys-cluster/hpx/hpx-0.9.9.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python{2_7,3_4} )
-inherit cmake-utils fortran-2 multilib python-single-r1 versionator
+inherit cmake-utils fortran-2 multilib python-any-r1 versionator
MY_PV="$(replace_version_separator _ -)"
@@ -31,17 +31,17 @@ RDEPEND="
"
DEPEND="${RDEPEND}
virtual/pkgconfig
- test? ( dev-lang/python )
+ test? ( ${PYTHON_DEPS} )
doc? ( >=dev-libs/boost-1.56.0-r1[tools] )
"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
jemalloc? ( !perftools !tbb )
perftools? ( !jemalloc !tbb )
tbb? ( !jemalloc !perftools )
"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {
diff --git a/sys-cluster/hpx/hpx-0.9.99.ebuild b/sys-cluster/hpx/hpx-0.9.99.ebuild
index b440abe724f0..c7977e7361c5 100644
--- a/sys-cluster/hpx/hpx-0.9.99.ebuild
+++ b/sys-cluster/hpx/hpx-0.9.99.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ else
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 multilib python-single-r1
+inherit cmake-utils fortran-2 multilib python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
@@ -38,14 +38,14 @@ DEPEND="${RDEPEND}
test? ( ${PYTHON_DEPS} )
doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
jemalloc? ( !perftools !tbb )
perftools? ( !jemalloc !tbb )
tbb? ( !jemalloc !perftools )
"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {
diff --git a/sys-cluster/hpx/hpx-1.0.0.ebuild b/sys-cluster/hpx/hpx-1.0.0.ebuild
index f9748b81ba22..93c3d5be3feb 100644
--- a/sys-cluster/hpx/hpx-1.0.0.ebuild
+++ b/sys-cluster/hpx/hpx-1.0.0.ebuild
@@ -15,7 +15,7 @@ else
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 multilib python-single-r1
+inherit cmake-utils fortran-2 multilib python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
@@ -38,14 +38,14 @@ DEPEND="${RDEPEND}
test? ( ${PYTHON_DEPS} )
doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
jemalloc? ( !perftools !tbb )
perftools? ( !jemalloc !tbb )
tbb? ( !jemalloc !perftools )
"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index b440abe724f0..c7977e7361c5 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ else
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 multilib python-single-r1
+inherit cmake-utils fortran-2 multilib python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
@@ -38,14 +38,14 @@ DEPEND="${RDEPEND}
test? ( ${PYTHON_DEPS} )
doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
"
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
jemalloc? ( !perftools !tbb )
perftools? ( !jemalloc !tbb )
tbb? ( !jemalloc !perftools )
"
pkg_setup() {
- use test && python-single-r1_pkg_setup
+ use test && python-any-r1_pkg_setup
}
src_configure() {