summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2022-12-30 19:22:38 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2022-12-30 19:26:22 +0100
commitb80c10b9f9bd027e1a9aaefe5a3569023de54621 (patch)
tree6fcc7b2f8867205f48f619e7192d5ed3cc545957
parentnet-wireless/iwd: Stabilize 2.0 ppc64, #888990 (diff)
downloadgentoo-b80c10b9.tar.gz
gentoo-b80c10b9.tar.bz2
gentoo-b80c10b9.zip
app-text/zathura: 0.5.2 version bump
Disabled seccomp tests as those seems to require other dependencies like plugins and files to be installed that are not part of this package, no way to get them working in the scope of what portage tests. Closes: https://bugs.gentoo.org/743070 Closes: https://bugs.gentoo.org/885445 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
-rw-r--r--app-text/zathura/Manifest1
-rw-r--r--app-text/zathura/files/zathura-disable-seccomp-tests.patch22
-rw-r--r--app-text/zathura/zathura-0.5.2.ebuild60
3 files changed, 83 insertions, 0 deletions
diff --git a/app-text/zathura/Manifest b/app-text/zathura/Manifest
index fe867e8053fd..590059c04fb6 100644
--- a/app-text/zathura/Manifest
+++ b/app-text/zathura/Manifest
@@ -1 +1,2 @@
DIST zathura-0.4.9.tar.gz 206194 BLAKE2B 0dd4b153cf7f8e3ddd4ede5514389b2c5e4aa88e2c416646acc38f7e19419e11165c2a5b51548a05d69a1b947e661b885f7c9d8c100179d0d23d8754cb441d97 SHA512 fbab65cba7ac37e4021233a4ae0356a85f4a88d2c1a2d8337cd627eae389856b6b4e692904233332d2fa14ad0300e8c52732059a75314a0ef147a02ca9f8db10
+DIST zathura-0.5.2.tar.gz 208606 BLAKE2B fc7e8042a373a3fd66973fd5d6c7c3e7d6da884fb40269545e4074b42fdbc9b6f286089769a435394812e24a8b24de328521a2fd797bbb13c16115b112dd9a48 SHA512 17f2a6535b2b3c6f61986cd8a6ccdef2c1a129d8ebf8c86cbe3c8eac868c2780801f3fe2fdc17c429ca0c63a71a328bbb6c7f814f82714dd7f1a5a4728663b1f
diff --git a/app-text/zathura/files/zathura-disable-seccomp-tests.patch b/app-text/zathura/files/zathura-disable-seccomp-tests.patch
new file mode 100644
index 000000000000..f3d88a2746d2
--- /dev/null
+++ b/app-text/zathura/files/zathura-disable-seccomp-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/tests/meson.build b/tests/meson.build
+index ac7edb8..68216f3 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -25,17 +25,6 @@ if check.found()
+ timeout: 60*60
+ )
+
+- if seccomp.found()
+- sandbox = executable('test_sandbox', ['test_sandbox.c', 'tests.c'],
+- dependencies: build_dependencies + test_dependencies,
+- include_directories: include_directories,
+- c_args: defines + flags
+- )
+- test('sandbox', sandbox,
+- timeout: 60*60
+- )
+- endif
+-
+ utils = executable('test_utils', ['test_utils.c', 'tests.c'],
+ dependencies: build_dependencies + test_dependencies,
+ include_directories: include_directories,
diff --git a/app-text/zathura/zathura-0.5.2.ebuild b/app-text/zathura/zathura-0.5.2.ebuild
new file mode 100644
index 000000000000..a348aaac0cce
--- /dev/null
+++ b/app-text/zathura/zathura-0.5.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson virtualx xdg
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="https://pwmt.org/projects/zathura/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="doc seccomp sqlite synctex test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=dev-libs/girara-0.3.7
+ >=dev-libs/glib-2.50:2
+ >=sys-devel/gettext-0.19.8
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.22:3
+ sys-apps/file
+ seccomp? ( sys-libs/libseccomp )
+ sqlite? ( >=dev-db/sqlite-3.5.9:3 )
+ synctex? ( app-text/texlive-core )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-libs/appstream-glib
+ dev-libs/check )
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/zathura-disable-seccomp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dconvert-icon=disabled
+ -Dmanpages=$(usex doc enabled disabled)
+ -Dseccomp=$(usex seccomp enabled disabled)
+ -Dsqlite=$(usex sqlite enabled disabled)
+ -Dsynctex=$(usex synctex enabled disabled)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}