summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-30 11:05:02 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-30 11:06:06 +0100
commitb81bdfbd427e687819f919847dbed2827bc7515e (patch)
tree2b1e9737a40edc14779f43f76d46ca1c9a92d5a8
parentx11-misc/synergy: Bump to 1.12.0 (diff)
downloadgentoo-b81bdfbd427e687819f919847dbed2827bc7515e.tar.gz
gentoo-b81bdfbd427e687819f919847dbed2827bc7515e.tar.bz2
gentoo-b81bdfbd427e687819f919847dbed2827bc7515e.zip
dev-lua/luarocks: patch LUA_LIBDIR check
If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists, as no compiled modules are installed on a new, fresh installation, so this check must be disabled, otherwise 'configure' will fail. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luarocks/luarocks-3.4.0-r100.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-lua/luarocks/luarocks-3.4.0-r100.ebuild b/dev-lua/luarocks/luarocks-3.4.0-r100.ebuild
index 4a4286ebda05..8075c2212cfd 100644
--- a/dev-lua/luarocks/luarocks-3.4.0-r100.ebuild
+++ b/dev-lua/luarocks/luarocks-3.4.0-r100.ebuild
@@ -36,6 +36,15 @@ BDEPEND="
)
"
+src_prepare() {
+ default
+
+ # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
+ # as no compiled modules are installed on a new, fresh installation,
+ # so this check must be disabled, otherwise 'configure' will fail.
+ sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
+}
+
src_configure() {
local myeconfargs=(
"--prefix=${EPREFIX}/usr"