summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 18:48:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 19:34:41 +0200
commitb81c52bcc175f89dba332a554e8d4a21568c8811 (patch)
treeca5c23556d379f31a50a31ba80c939c585787e62
parentdev-ros/gazebo_ros_control: bump eapi (diff)
downloadgentoo-b81c52bcc175f89dba332a554e8d4a21568c8811.tar.gz
gentoo-b81c52bcc175f89dba332a554e8d4a21568c8811.tar.bz2
gentoo-b81c52bcc175f89dba332a554e8d4a21568c8811.zip
dev-ros/gazebo_ros: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
index ca217b085352..fcbce5b78daf 100644
--- a/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
+++ b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
CATKIN_HAS_MESSAGES=yes
ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+DESCRIPTION="ROS plugins that offer messages and services for interfacing with gazebo"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
@@ -27,10 +26,13 @@ RDEPEND="
dev-ros/dynamic_reconfigure
dev-libs/libxml2
dev-libs/boost:=[threads]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-DEPEND="${RDEPEND}"