summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-09 08:33:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-09 09:07:43 +0100
commitb827686140c5bcf4e9bcff0e76e4c7470a7cdc28 (patch)
tree7f3d610c0464bb90f349a6c2b19534ecc6d3f2ff
parentdev-python/hypothesis: Bump to 6.0.0 (diff)
downloadgentoo-b8276861.tar.gz
gentoo-b8276861.tar.bz2
gentoo-b8276861.zip
dev-python/cfn-python-lint: Bump to 0.44.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-python-lint/Manifest1
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.44.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/cfn-python-lint/Manifest b/dev-python/cfn-python-lint/Manifest
index ee2006daa87f..4442475a3ff7 100644
--- a/dev-python/cfn-python-lint/Manifest
+++ b/dev-python/cfn-python-lint/Manifest
@@ -2,3 +2,4 @@ DIST cfn-python-lint-0.43.0.tar.gz 5329573 BLAKE2B 94ea659e3df02fb3b269984cdf6d8
DIST cfn-python-lint-0.44.0.tar.gz 5339555 BLAKE2B 880f03384247f4d6af1e87850b367bdc0846e00205aa943480a3028760115e36b3f6180f536a7b16b9a1aaf9f824ceaea5ab69b7adb1da3f345506c0268b55c0 SHA512 15ee6cc0cb373f7104d9c32acb06433b5669ae89997de010f1c4f382514481f1c6b87ceb387236275299e13e63aae1a5345e71ee934f2d99c1b66e566e1ef245
DIST cfn-python-lint-0.44.1.tar.gz 5339578 BLAKE2B 7982cba9fe422a8323c6ea270bd7ff5f41800cc16ceaa39d9fc01c2929cda5cca3b19c45de50ca8338a56aad001c834e16bfbd0ab59140381b5189e28965ba38 SHA512 b7f9ad598411d89979334aa79c7b4667ede28eef82b0b546977ba10f33f57e89366d1448e8ceeb3f28a2e53b33a409c439c3faf7d10f53fc5819f6b8693e117d
DIST cfn-python-lint-0.44.2.tar.gz 5515542 BLAKE2B 9da951dc7faa000d2abd1610595e463045079e5a2e73ad59779fb715f32fca39c1cef189484d62de3bc57a48b7776f5cebcc21c39948b7d73e394b89a4cebba9 SHA512 ca0cba19f930960711676ec285b10e0b60ff36359326098d5040bd2fd8f7ca6cfee985544c4bf94770baefa0e50eecead45c4d769ff3587031c3bf463f26355f
+DIST cfn-python-lint-0.44.3.tar.gz 5591470 BLAKE2B 7d8f6763023a86d528f132b36b9b860b726241576037a1dd92a296f4b5ec5389ffe24e4a41a8f504ae8351b9dafc166d96ae3b17b90ac23062af2159baa36220 SHA512 a3c5fa435ed9afce32336d01cfc6c94d1965dc5c296601aba75064fdaecda9df5bfaf2976837729b56f00bc3e8cea7fe8cd5141c58335091a35dbec31a630b69
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.44.3.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.44.3.ebuild
new file mode 100644
index 000000000000..2db0beee00fd
--- /dev/null
+++ b/dev-python/cfn-python-lint/cfn-python-lint-0.44.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-python-lint"
+SRC_URI="https://github.com/aws-cloudformation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.25.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' python3_6)
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install unittest
+
+PATCHES=(
+ "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ # requires git checkout
+ sed -e 's:test_update_docs:_&:' \
+ -i test/unit/module/maintenance/test_update_documentation.py || die
+ distutils-r1_src_prepare
+}