summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-07-10 22:20:53 +0100
committerMarek Szuba <marecki@gentoo.org>2023-07-11 00:04:16 +0100
commitb84164aab5125ba5963e300d4bb52a149574733d (patch)
tree989220ba136edc7ce2ba13ab26605520357f0665
parentdev-python/mkdocs-ansible: drop 0.1.4, 0.1.5 (diff)
downloadgentoo-b84164aab5125ba5963e300d4bb52a149574733d.tar.gz
gentoo-b84164aab5125ba5963e300d4bb52a149574733d.tar.bz2
gentoo-b84164aab5125ba5963e300d4bb52a149574733d.zip
dev-python/mkdocs-ansible: add missing dependencies
Closes: https://bugs.gentoo.org/907820 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/mkdocs-ansible/files/mkdocs-ansible-0.1.6-prune_deps.patch20
-rw-r--r--dev-python/mkdocs-ansible/mkdocs-ansible-0.1.6-r1.ebuild41
-rw-r--r--dev-python/mkdocs-ansible/mkdocs-ansible-0.1.6.ebuild24
3 files changed, 61 insertions, 24 deletions
diff --git a/dev-python/mkdocs-ansible/files/mkdocs-ansible-0.1.6-prune_deps.patch b/dev-python/mkdocs-ansible/files/mkdocs-ansible-0.1.6-prune_deps.patch
new file mode 100644
index 000000000000..dd6b81b59a84
--- /dev/null
+++ b/dev-python/mkdocs-ansible/files/mkdocs-ansible-0.1.6-prune_deps.patch
@@ -0,0 +1,20 @@
+As of 0.1.6, no mention of pipdeptree anywhere in the actual code.
+
+--- a/.config/requirements.in
++++ b/.config/requirements.in
+@@ -11,5 +11,4 @@
+ mkdocstrings-python>=0.8.3
+ mkdocstrings>=0.21.2
+ pillow>=9.4.0
+-pipdeptree>=2.4.0
+ pymdown-extensions>=9.9.2
+--- a/.config/requirements.txt
++++ b/.config/requirements.txt
+@@ -39,7 +39,6 @@
+ mkdocstrings-python==1.1.0
+ packaging==23.1
+ pillow==9.5.0
+-pipdeptree==2.7.1
+ pycparser==2.21
+ pygments==2.15.1
+ pymdown-extensions==10.0.1
diff --git a/dev-python/mkdocs-ansible/mkdocs-ansible-0.1.6-r1.ebuild b/dev-python/mkdocs-ansible/mkdocs-ansible-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..f13655d4f5dc
--- /dev/null
+++ b/dev-python/mkdocs-ansible/mkdocs-ansible-0.1.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Ansible theme for MkDocs"
+HOMEPAGE="
+ https://github.com/ansible/mkdocs-ansible/
+ https://pypi.org/project/mkdocs-ansible/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/markdown-exec-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/markdown-include-0.8.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-gen-files-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-htmlproofer-plugin-0.10.2[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-material-extensions-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-material-9.0.13[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-minify-plugin-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-monorepo-plugin-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-python-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-0.21.2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-9.9.2[${PYTHON_USEDEP}]
+ >=media-gfx/cairosvg-2.6.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1.6-prune_deps.patch
+)
diff --git a/dev-python/mkdocs-ansible/mkdocs-ansible-0.1.6.ebuild b/dev-python/mkdocs-ansible/mkdocs-ansible-0.1.6.ebuild
deleted file mode 100644
index 34e33cbb072c..000000000000
--- a/dev-python/mkdocs-ansible/mkdocs-ansible-0.1.6.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Ansible theme for MkDocs"
-HOMEPAGE="
- https://github.com/ansible/mkdocs-ansible/
- https://pypi.org/project/mkdocs-ansible/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- dev-python/mkdocs-material[${PYTHON_USEDEP}]
-"