summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-19 21:08:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-19 21:08:50 +0300
commitb841f47b3f3b916ab0ebc52982447bd38d60e6ab (patch)
treeee2db0cd659bf270b77cd5ed4800148e1b6e0927
parentapp-vim/vim-spell-es: Stabilize 20060208-r2 ALLARCHES, #932222 (diff)
downloadgentoo-b841f47b3f3b916ab0ebc52982447bd38d60e6ab.tar.gz
gentoo-b841f47b3f3b916ab0ebc52982447bd38d60e6ab.tar.bz2
gentoo-b841f47b3f3b916ab0ebc52982447bd38d60e6ab.zip
media-libs/liblingoteach: update EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--media-libs/liblingoteach/liblingoteach-0.2.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/liblingoteach/liblingoteach-0.2.3-r1.ebuild b/media-libs/liblingoteach/liblingoteach-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..cf498135095d
--- /dev/null
+++ b/media-libs/liblingoteach/liblingoteach-0.2.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A library to support lingoteach-ui and for generic lesson development"
+HOMEPAGE="http://lingoteach.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/lingoteach/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug zlib"
+
+RDEPEND="
+ zlib? ( sys-libs/zlib )
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable zlib compression)
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ mv "${ED}/usr/share/doc/${P}" "${ED}/usr/share/doc/${PF}" || die
+}