summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-01-12 10:28:54 +0100
committerJeroen Roovers <jer@gentoo.org>2017-01-12 10:28:54 +0100
commitb855270c5ed8015ca7d91c7a22979fab799b8fec (patch)
tree15a5131eaafae270f1ee3d59462d58f546533d27
parentdev-libs/protobuf: Stable for HPPA (bug #603430). (diff)
downloadgentoo-b855270c5ed8015ca7d91c7a22979fab799b8fec.tar.gz
gentoo-b855270c5ed8015ca7d91c7a22979fab799b8fec.tar.bz2
gentoo-b855270c5ed8015ca7d91c7a22979fab799b8fec.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.01.10.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index bc90acd3cc06..cd5ba30dacb3 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.12.22.tar.gz 2502964 SHA256 f5bc5eb1af17391b7a1da795f4181c3702fb2c1da2668b25f1260dbdba882524 SHA512 87fee134da660a4feb4cfcd2cbb35cb9682e6ed08c766e3c89f6c986f991cac78c64f5bf8a1d15c4080e4df0909c6a360137407a7896b93f8f41cf4493f341cb WHIRLPOOL 6909d34958e4152be3334723c68d207bb34db2996d90908829ebd3ee45d28768d7f6cba8ce0fb19de440b34fb96b46b3d5b8bf830c998037c4f4d59e574206c3
DIST youtube-dl-2016.12.31.tar.gz 2508506 SHA256 94d9f6cb99a1f5c27a8885f1bffe1f36c7e89feef961a83f78d8093284cf1ec9 SHA512 10e04d2579ce555125aa4f9ffc64a1648b6245643e42eac30428a165037172fe1b59b12830c88e1f88c1dd621ebe59a9ab2136e9da45e20a205b1543c5da2212 WHIRLPOOL 88161cc147ae4d045662945f10b0bd9e261ed7a300dba61aeaa917cefaa5341c7d126fe2e726d48cfdf98ade1f6384d0f7bf6a1c0ec5458ded9278e74d06e484
DIST youtube-dl-2017.01.05.tar.gz 2513210 SHA256 7670471d6000eebb17f5edf0c405bb3b2b99b20c6f500b6bbfb2d5678ecf3da6 SHA512 090d76ab2b2334b62d5e52f96c66c66d56b6f0e82a43182bff4593c733ce615b7299624ed9a97d4ffb9db41f4beba4336538abbb55c87692c402102f43a5795b WHIRLPOOL c10462d918f257005a57f91796aae7ef49a0887d6bff3b1fb5bad6bedd83dfdae0b2cfc7749a7e72f05829a9cfd47041810732b7d674d0fde30cb89dda0f666b
+DIST youtube-dl-2017.01.10.tar.gz 2517299 SHA256 6493d1400c5735221d65688548ada4d45875f25562f7c49c73263d9ae4369932 SHA512 c5c8a1b9650e0580a9b0243e71401427dd9806e9bc588140d2fa7cb32fc8889361164d175c9660363f67b762a6283a7de5948135c25fb210e6da771b94423a42 WHIRLPOOL 0e2a2d7a6bf1ecce4a599606772cb0e6b00e43920d6961a612b158f1e1e2906d71cb2f9d0158dbcb7c446201017649d67523782e2c6c11b0b5f2ecae9d48bc6b
diff --git a/net-misc/youtube-dl/youtube-dl-2017.01.10.ebuild b/net-misc/youtube-dl/youtube-dl-2017.01.10.ebuild
new file mode 100644
index 000000000000..6cb33319c36f
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.01.10.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}