summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-11-04 11:04:47 +0100
committerMatt Turner <mattst88@gentoo.org>2020-11-04 20:38:21 -0500
commitb88fb2dab545e28e6d9c3a8b84f3edc2842c5f82 (patch)
tree746c0f3ad113cab4925e7a51cc6e289de806749e
parentdev-python/python-language-server: version bump 0.36.0 (diff)
downloadgentoo-b88fb2dab545e28e6d9c3a8b84f3edc2842c5f82.tar.gz
gentoo-b88fb2dab545e28e6d9c3a8b84f3edc2842c5f82.tar.bz2
gentoo-b88fb2dab545e28e6d9c3a8b84f3edc2842c5f82.zip
dev-python/ropemode: bump python targets to py3.8
drop py3.6 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-python/ropemode/ropemode-0.5.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/ropemode/ropemode-0.5.ebuild b/dev-python/ropemode/ropemode-0.5.ebuild
index 2c3fb327d4cc..eb540c46a0a4 100644
--- a/dev-python/ropemode/ropemode-0.5.ebuild
+++ b/dev-python/ropemode/ropemode-0.5.ebuild
@@ -3,11 +3,11 @@
EAPI=7
-# Currently (2020-03-23) rope is blocking
-# support for python 3.8.
+# Currently (2020-11-04) rope is blocking
+# support for python 3.9.
# For details see
-# https://github.com/python-rope/rope/pull/285
-PYTHON_COMPAT=( python3_{6,7} )
+# https://github.com/python-rope/rope/issues/299
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
@@ -20,11 +20,8 @@ SRC_URI="https://github.com/python-rope/ropemode/archive/${PV}.tar.gz -> ${P}.ta
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="dev-python/rope[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
"${PYTHON}" ropemodetest.py || die "tests failed with ${EPYTHON}"