summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-16 01:19:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-16 01:32:28 +0100
commitb8a1792fcdd76d1df47aee24089310bfc199d523 (patch)
tree25e404161e81949995c96e8fff35ce05b14591e5
parentdev-python/flufl-i18n: Bump to 3.1.5 (diff)
downloadgentoo-b8a1792fcdd76d1df47aee24089310bfc199d523.tar.gz
gentoo-b8a1792fcdd76d1df47aee24089310bfc199d523.tar.bz2
gentoo-b8a1792fcdd76d1df47aee24089310bfc199d523.zip
dev-python/cfn-python-lint: Bump to 0.45.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-python-lint/Manifest1
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.45.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/cfn-python-lint/Manifest b/dev-python/cfn-python-lint/Manifest
index 5e3b557c7908..e642092ab5b1 100644
--- a/dev-python/cfn-python-lint/Manifest
+++ b/dev-python/cfn-python-lint/Manifest
@@ -5,3 +5,4 @@ DIST cfn-python-lint-0.44.4.tar.gz 5632477 BLAKE2B 3520cb016f926e180bb1547b4e467
DIST cfn-python-lint-0.44.5.tar.gz 5657765 BLAKE2B e35fca9cf8232bc802666333184a52b544bad5858ec8e4c16fe435ea5c421ca25296bb9d8a3bf351276dc1e36ee3101cb0c950ca9d8ce87f5dd2f64cf347ba30 SHA512 e23e415f7d5dd3933e70e7c5b0d9d001bc9aefd0ec67ba9245b4cecbad0c5470376439c12d2cd532eb39e900a325de52c4856351bba2ca27cdc0760ed091ccca
DIST cfn-python-lint-0.44.6.tar.gz 5689226 BLAKE2B 19f6d4f09a621d8389893234dea2cc5c9e2e04fae7f1519bbd95657f5bf1ff97e34c1ed66a6f2bb0ffc2851e99cae5ea2734aacac58b87088a5430346ce0d102 SHA512 8c4414145e039d8b2b32008871dc0d2dbe946bd10eb9b7a78a070ce16ca13c3c0f4a37212bae07fa798b8b0d0868b342735ef406c6b651f6c85b8ec92bd563b2
DIST cfn-python-lint-0.44.7.tar.gz 5711448 BLAKE2B b38b90ca7d181dc655b07a0151acad6a22ed1a0d34223cb813c3257cceb0f9ef5ca175cd4992a9d72a843c2b40b0830c433cbbe8b71550c9c9c482ea62783142 SHA512 a4ed91383f80e437338f7afee55de5e7cb0f3f8690c4324de77f2d35a665e5947f07945449aedddbd9d996270495ee63418e38b97639c4b7852b1fe50e8ce6e4
+DIST cfn-python-lint-0.45.0.tar.gz 6259853 BLAKE2B d6b930ac2dcdb5b629e5bfc1cd37cd694355de16585712a55a2b5f1cf5e2f234668c180dc77c1904d9de1d588e2675523210bad0bdf69d5b9e9032d47e73c2e1 SHA512 d89a6fc6f2a29c3d8294b7daa033f22b5e2f45576d8cd6abc25a30c3039c4c539bab2a8c45cde094e2cf4482227a09b1da34abba0424861307ced91b957ce13c
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.45.0.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.45.0.ebuild
new file mode 100644
index 000000000000..c3edcec5c4eb
--- /dev/null
+++ b/dev-python/cfn-python-lint/cfn-python-lint-0.45.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-python-lint"
+SRC_URI="https://github.com/aws-cloudformation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.25.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' python3_6)
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install unittest
+
+PATCHES=(
+ "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ # requires git checkout
+ sed -e 's:test_update_docs:_&:' \
+ -i test/unit/module/maintenance/test_update_documentation.py || die
+ # requires Internet
+ sed -e 's:test_update_resource_specs_python:_&:' \
+ -i test/unit/module/maintenance/test_update_resource_specs.py || die
+ distutils-r1_src_prepare
+}