summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-14 22:12:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-14 22:37:46 +0100
commitb8b508ee38993273b56f7aa4e7cadca730a8407d (patch)
treec46cf5d4b908f4557681913f3305e7aecb929f93
parentdev-python/identify: Bump to 2.4.10 (diff)
downloadgentoo-b8b508ee.tar.gz
gentoo-b8b508ee.tar.bz2
gentoo-b8b508ee.zip
dev-python/lz4: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/lz4-4.0.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index 412d75d8147d..f1ff1e096448 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1 +1,2 @@
DIST lz4-3.1.10.tar.gz 162886 BLAKE2B d87a84e619b62b0fb13c942c5bee1ba78c1457e1f8bef093d5be732ea6b1481ad1de38a3e3e9e3479fb407477d43183b376fd1ce2a2b5d6289d293a6c79dc414 SHA512 61983e77fa445f59503ccf8ed5fe0605d79754cdeb166e16a7093a856b23369634db7d105d57b3829e680dad0a3728adec9d18dccd92c994347b74c5af95580e
+DIST lz4-4.0.0.tar.gz 163729 BLAKE2B ce617f2aea3f45cf9fb0bf642599a1d872d9532ab465d32602b63987081a7e78ab4ac4373a41c6a97ec50eb6f2debc078288554966390651325ba166faa79c0d SHA512 885d215dd4caadc84d1e2a9575be9972a33a43af089f0788192c9f4f53382c0937f9d67aac412e2860c9ba393ee3bb15dfe273865acb6a3cf8aecdce8292ecc9
diff --git a/dev-python/lz4/lz4-4.0.0.ebuild b/dev-python/lz4/lz4-4.0.0.ebuild
new file mode 100644
index 000000000000..ae6cd449b253
--- /dev/null
+++ b/dev-python/lz4/lz4-4.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-arch/lz4:="
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+)