summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2021-02-27 05:35:14 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2021-02-27 05:35:14 -0500
commitb8ba237389d58f2fec3c55f1ddda6540bece8cc2 (patch)
tree0cd8bc85bb1e21af76ed00c5cefb2a32aaec78c8
parentdev-libs/papi: need static-libs on dev-libs/libpfm (diff)
downloadgentoo-b8ba237389d58f2fec3c55f1ddda6540bece8cc2.tar.gz
gentoo-b8ba237389d58f2fec3c55f1ddda6540bece8cc2.tar.bz2
gentoo-b8ba237389d58f2fec3c55f1ddda6540bece8cc2.zip
sci-geosciences/osm2pgsql: Cleanup
Closes: https://bugs.gentoo.org/688110 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
-rw-r--r--sci-geosciences/osm2pgsql/Manifest1
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-1.3.0.ebuild43
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-1.4.0.ebuild43
3 files changed, 0 insertions, 87 deletions
diff --git a/sci-geosciences/osm2pgsql/Manifest b/sci-geosciences/osm2pgsql/Manifest
index a077a0e2ab63..bfae50571f56 100644
--- a/sci-geosciences/osm2pgsql/Manifest
+++ b/sci-geosciences/osm2pgsql/Manifest
@@ -1,2 +1 @@
-DIST osm2pgsql-1.3.0.tar.gz 2460451 BLAKE2B ac52523bf6d35a06528ad22a51465388e70baf9f94bb3664c39c301b429ff453370d9cd44549781e4ee50d698094ddfe83f0e39a7c3d6c01556ea95e10feaf75 SHA512 e643f3a1987ead36763c96d34b5dd7e170273b77a521106c21311dc7b01d2b34470b2e00e3214050f2cbdd3d89703a1827ee6c35928ed77cc7f35fc4e20331f3
DIST osm2pgsql-1.4.0.tar.gz 2429430 BLAKE2B 5d93a159a87c9cb12d85be8b89377f720e0d94564574f70d6f3686b215a99250967655d0eeee3dcda2742fcab356ecf62de2b4bab384d69a641a06829c401388 SHA512 f0eaceb7f78087a58bba3bbfafbb9d6d70aecd4c3ba1cfb0ce784116b52a57c69855c1a7459cce8b963c87955de269ca320cf4a3934b6ff5ad29b7554e07dd9e
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-1.3.0.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-1.3.0.ebuild
deleted file mode 100644
index 1e47df20181e..000000000000
--- a/sci-geosciences/osm2pgsql/osm2pgsql-1.3.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
-HOMEPAGE="https://osm2pgsql.org/"
-SRC_URI="https://github.com/openstreetmap/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+lua luajit"
-
-COMMON_DEPEND="
- app-arch/bzip2
- dev-db/postgresql:=
- dev-libs/expat
- sci-libs/proj:=
- sys-libs/zlib
- lua? ( dev-lang/lua:0= )
- luajit? ( dev-lang/luajit:= )
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/boost
-"
-RDEPEND="${COMMON_DEPEND}
- dev-db/postgis
-"
-
-# Tries to connect to local postgres server and other shenanigans
-RESTRICT="test"
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_LUA=$(usex lua)
- -DWITH_LUAJIT=$(usex luajit)
- -DBUILD_TESTS=OFF
- )
- cmake_src_configure
-}
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-1.4.0.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-1.4.0.ebuild
deleted file mode 100644
index 736fa938d656..000000000000
--- a/sci-geosciences/osm2pgsql/osm2pgsql-1.4.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
-HOMEPAGE="https://osm2pgsql.org/"
-SRC_URI="https://github.com/openstreetmap/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+lua luajit"
-
-COMMON_DEPEND="
- app-arch/bzip2
- dev-db/postgresql:=
- dev-libs/expat
- sci-libs/proj:=
- sys-libs/zlib
- lua? ( dev-lang/lua:0= )
- luajit? ( dev-lang/luajit:= )
-"
-DEPEND="${COMMON_DEPEND}
- dev-libs/boost
-"
-RDEPEND="${COMMON_DEPEND}
- dev-db/postgis
-"
-
-# Tries to connect to local postgres server and other shenanigans
-RESTRICT="test"
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_LUA=$(usex lua)
- -DWITH_LUAJIT=$(usex luajit)
- -DBUILD_TESTS=OFF
- )
- cmake_src_configure
-}