summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-10-11 09:16:30 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-19 16:52:29 +0200
commitb8e4b077ff52dc71a670edde4819363d8903408a (patch)
tree31f920f786b83743047549e1de0b820c56cb1043
parentmedia-gfx/gthumb: Version bump to 3.12.4 (diff)
downloadgentoo-b8e4b077.tar.gz
gentoo-b8e4b077.tar.bz2
gentoo-b8e4b077.zip
app-editors/ghex: Version bump to 45.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33299 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-45.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index 5b4ed5725b52..07ff056efc6d 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1,2 +1,3 @@
DIST ghex-44.2.tar.xz 897944 BLAKE2B 0db001b90390f7747792ac89a5daaf9d38165b72dce77c3a2fd41914a4386001b9f15aaf4352a3b41a204a9104a5234a6ac50a3a7269e10a151c000d57228480 SHA512 a06876e06488bb25b17fbdf17ea73e57f563fe49a414c173d680a6bf4db9b66b40fce90ad67cfb73c62f25d88f436a58b7e0fd588c7a664faf78c5058524cabf
+DIST ghex-45.0.tar.xz 902480 BLAKE2B 9001be3c01a3f5974606180cede15e753ccda0ec6f4fa77cdaf3aea5030117d303b5cb4fb68dfb09de6aee87d76baf689ae250be457c41b8e4c9d3387b691e90 SHA512 1f6fa7da2e4cfcb89113780d2a0333ee322d608be3e7fccb958ea19a3c3fc368363597b99ff27bd54c929ab3e3afdb5d5f1dbe810d3ec04d9dd2c114bfc71c0f
DIST ghex-45.beta.tar.xz 899044 BLAKE2B 4b37a882a6626c16349ac0671e1b049d9fdb166262cce0605bf84ba5d099354647fa61f380a18f217bf20f80570de64d946dec97a05bc47441ed641c847cc6b8 SHA512 5a35fe4449ffda75e587fb55d8ef641e054cb079b880c7750c00ceb61c207fbfee649b16a53c639c7108ced35efa0cfc2e092da3197dd6b5af116ec737e4c773
diff --git a/app-editors/ghex/ghex-45.0.ebuild b/app-editors/ghex/ghex-45.0.ebuild
new file mode 100644
index 000000000000..4562fb2fe62e
--- /dev/null
+++ b/app-editors/ghex/ghex-45.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}