summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-05-17 00:16:55 -0500
committerMatthias Maier <tamiko@gentoo.org>2021-05-17 00:17:37 -0500
commitb8e6764087fb5f5559f2cda70bc24ebcdbeb0b41 (patch)
tree78edbe8dac2898b23b051c32b1cca684df4bc1dc
parentdev-vcs/mr: mark stable with ALLARCHES policy (diff)
downloadgentoo-b8e67640.tar.gz
gentoo-b8e67640.tar.bz2
gentoo-b8e67640.zip
dev-vcs/vcsh: version bump to 20190621.4
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--dev-vcs/vcsh/Manifest1
-rw-r--r--dev-vcs/vcsh/vcsh-1.20190621.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-vcs/vcsh/Manifest b/dev-vcs/vcsh/Manifest
index 1e7936a81be3..f8987fdd7db7 100644
--- a/dev-vcs/vcsh/Manifest
+++ b/dev-vcs/vcsh/Manifest
@@ -1 +1,2 @@
DIST vcsh-1.20151229.1.tar.gz 38309 BLAKE2B 9f9bb6fecfbfb01a88f7f0fb15cac3d83cb470ee6a73bfbbf2fde11b6d0bc7b8ea70da0c527563b4c06caa261fde98273baa80623783bef7345e02380d005f04 SHA512 da26044aa9bf884c178b1a2493f6bb4bea978d39d97f0dd31aef0130bac375ef2e519a3f7a14087467a3fccfd815f11c0718ca0f668d61dd91c97ac74af8afeb
+DIST vcsh-1.20190621.4.tar.gz 40262 BLAKE2B 541f0fe4873236d6b2af2f2a71c446954ca401b69beeca9b21c61a51e3cff11fd1999addcdf4f5d699ff54fa08e6b81a33e0b6d586cad250470e4646cbd5edd9 SHA512 d86168198f468bbf74d7c83dfe61e07e39772c98467b713f7a4972b779f046c51a2c983ddd444d0332d2a586159d86ccb6560d4cffb5a6441534c425a717ffe3
diff --git a/dev-vcs/vcsh/vcsh-1.20190621.4.ebuild b/dev-vcs/vcsh/vcsh-1.20190621.4.ebuild
new file mode 100644
index 000000000000..20daa45b2ae0
--- /dev/null
+++ b/dev-vcs/vcsh/vcsh-1.20190621.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION='Manage config files in $HOME via fake bare git repositories'
+HOMEPAGE="https://github.com/RichiH/vcsh/"
+
+MY_PV="$(ver_rs 2 '-')"
+SRC_URI="https://github.com/RichiH/vcsh/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="dev-vcs/git"
+DEPEND=""
+
+DOCS=( changelog README.md CONTRIBUTORS )
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's,vendor-completions,site-functions,' \
+ -e "s,\(\$(DOCDIR_PREFIX)\)/\$(self),\1/${PF}," \
+ Makefile || die "sed failed"
+
+ # remove dysfunctional tests
+ sed -i -e 's,install: all,install:,' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ default
+ dodoc -r doc/sample_hooks
+}