summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-06-29 07:57:39 +0100
committerMarek Szuba <marecki@gentoo.org>2022-06-29 08:17:38 +0100
commitb906cca008b131d382cd331d8e2919b883b3cc5f (patch)
treee3537cb5df84d302f7f82725a4e102a8ee6115ca
parentsys-libs/liburing: add missing || die on configure (diff)
downloadgentoo-b906cca008b131d382cd331d8e2919b883b3cc5f.tar.gz
gentoo-b906cca008b131d382cd331d8e2919b883b3cc5f.tar.bz2
gentoo-b906cca008b131d382cd331d8e2919b883b3cc5f.zip
app-backup/borgmatic: add 1.6.4
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.6.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 06ba6bd8b6ad..45f95ca2d1bc 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,3 +1,4 @@
DIST borgmatic-1.5.24.tar.gz 291853 BLAKE2B d8c695c8faf713cd75e994d8ae7633674d01981047ce79d35d392b9db5a2dfb47c2be4a91e0f183ab2ead5877ee68983d0fdfd88ae7d28355d8029d39cbfdc04 SHA512 cfa1bd1dc6119497fba99d02e4f53322aede907ba8b30068b6c1dadc67f5e30466d2f1f0d83f1f15f71dfac08ef5b0adb376d24d62f1cd44992e7a45f99fde34
DIST borgmatic-1.6.1.tar.gz 300375 BLAKE2B b56c31da62591b8bfd3c0146e77cab7ab28f942c59ca0f6cf7342d80bc31249dfcbd59fae13025a0fe464de326b6758169be983d2b741ecc37062961541fb892 SHA512 c48fb89167ce188feeb9d51ae9caabf985f9c583d09840d3dd4aaf772a4acbd3c22399958740820b9fbf61603769a604dc92b72448e2c7196fae855549f3c6d5
DIST borgmatic-1.6.3.tar.gz 320186 BLAKE2B 232c2878b0778f039b0c2fa7e6b4de37477b81c13082772752a78e8de0fff0b52fb6976a02ae6f13d9a33a74d96c2689ceee48f97d85381a2d06d0b61f6bb658 SHA512 eadca728680d86dc16c8444ac653c46e9c61e49f3eced1228d46ff77138e44985ee794dd21921f829db063106cdd697c997677bd983bf000aedb89c6c00c8f5d
+DIST borgmatic-1.6.4.tar.gz 322306 BLAKE2B 48d01b56065f08db464ffab71cfdc6c2924ed899e07a6788f37217448d19d15d59ee3771ad545bf1c576da6a26d754f8c24eea82361d77fa616bebb54a6dd878 SHA512 8d0d4b1b6bbb562fcab49a8ba2cfd1d33f6e5053566096a6f01b83b2f69c37a437836d78d3547100f66bb1320c1e028a2223fcc2285ed0fb8d463c8d6eae5819
diff --git a/app-backup/borgmatic/borgmatic-1.6.4.ebuild b/app-backup/borgmatic/borgmatic-1.6.4.ebuild
new file mode 100644
index 000000000000..f48f145dc769
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.6.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.5.16-systemd_service_bin_path.patch
+)
+
+# test_borgmatic_version_matches_news_version tries to run the 'borgmatic'
+# executable so making it work would require passing --install
+# to distutils_enable_tests. Given that this is the only test requiring
+# this and that all it does is make sure the NEWS file has been updated
+# for the current version, just skip it.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}