summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-12 03:22:59 +0100
committerSam James <sam@gentoo.org>2023-05-12 03:55:38 +0100
commitb926571bdf222767f4db79adc3a84e7cc7ff2368 (patch)
treee157cabde96a235eb02c8e85c474a3c273f8de98
parentmedia-plugins/mda-lv2: wire up tests; fix LICENSE; fix strict aliasing (diff)
downloadgentoo-b926571b.tar.gz
gentoo-b926571b.tar.bz2
gentoo-b926571b.zip
media-sound/mpdscribble: wire up (restricted) tests
They're interactive/manual. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.24.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/media-sound/mpdscribble/mpdscribble-0.24.ebuild b/media-sound/mpdscribble/mpdscribble-0.24.ebuild
index 69429a0bcd59..7b2faf2a00ae 100644
--- a/media-sound/mpdscribble/mpdscribble-0.24.ebuild
+++ b/media-sound/mpdscribble/mpdscribble-0.24.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,6 +15,9 @@ SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
+IUSE="test"
+# Test program is just an interactive check.
+RESTRICT="!test? ( test ) test"
RDEPEND="
dev-libs/boost
@@ -33,6 +36,14 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.23-gcc12-time.patch
)
+src_configure() {
+ local emesonargs=(
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
src_install() {
meson_src_install
newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble