summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-08-05 12:21:54 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-08-05 12:21:54 +0200
commitb92bad3749a68c8f322673c991c3ba563de1c2c8 (patch)
tree27aab8d0fb72e4c5a2f70ca3eea5ad2523300fbe
parentapp-editors/gedit: bump to 3.28.1 (diff)
downloadgentoo-b92bad37.tar.gz
gentoo-b92bad37.tar.bz2
gentoo-b92bad37.zip
app-misc/go-jira: Version bump to 1.0.20
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--app-misc/go-jira/Manifest1
-rw-r--r--app-misc/go-jira/go-jira-1.0.20.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/go-jira/Manifest b/app-misc/go-jira/Manifest
index 4777177926b7..3cb2a61efdf2 100644
--- a/app-misc/go-jira/Manifest
+++ b/app-misc/go-jira/Manifest
@@ -1,2 +1,3 @@
DIST go-jira-1.0.17.tar.gz 1382832 BLAKE2B 17cada8407b5136ec3b84d9f43c67cb25a893bdfeae7309bc15eb479954ba3ce7df4bc1248782a0bd1874b08b48a68a8e69a1651960c10d6260b22c63a0a8147 SHA512 8abbe6233413d12495399446adbb02d6a37aedf2a2b1a860c403b6e210f5e1f44fa01dfe937d86241486cb4a56c52530eff1c582d59f5ddde4b466a6908fd020
DIST go-jira-1.0.19.tar.gz 1292750 BLAKE2B 2377b5d677878e83d764d65fe3ef9c3388aa5999004adce956549b327e00554142f7fc82c724593652fd5b5a2d23e161b926bb3c34285f971df0bdac90c94a0a SHA512 42fb89f0886df19eac6cc7098da1e03a0e091876777de896a1b035b6f9d0cb5b546b8fb4c8d4469450da11e2a52b158256f959a63fc57ffeb4541cf792bf3b0f
+DIST go-jira-1.0.20.tar.gz 1292990 BLAKE2B 788dada892809df730988193e50bd1033b2efe4398cf1374c7c2a08c197e10215aa83feeb2b0573a04c7de72badf83089cd45da85d0e60a31d0fbf41615debae SHA512 f07e1fa6e24fa29a50e348490b0ebf6f3dfa1c1bcbc8420320f3c87b3fac74e6ff1d9acb8936fefb25debed2411508689f832eb19ce09f1c39657942c092220e
diff --git a/app-misc/go-jira/go-jira-1.0.20.ebuild b/app-misc/go-jira/go-jira-1.0.20.ebuild
new file mode 100644
index 000000000000..513090c2a8f9
--- /dev/null
+++ b/app-misc/go-jira/go-jira-1.0.20.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="gopkg.in/Netflix-Skunkworks/go-jira.v1"
+
+inherit golang-build golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="A simple JIRA commandline client in Go"
+HOMEPAGE="https://github.com/Netflix-Skunkworks/go-jira"
+SRC_URI="https://github.com/Netflix-Skunkworks/go-jira/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${WORKDIR}/${P}" go build -v -o jira cmd/jira/main.go || die
+ popd || die
+}
+
+src_install() {
+ dobin src/${EGO_PN}/jira
+ dodoc src/${EGO_PN}/{CHANGELOG,README}.md
+}