summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-12 21:53:21 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-12 22:51:46 -0500
commitb92f332b3b4a135c2e700ab4542ad917d8f5aefd (patch)
tree618508a2410e34801f8641ff47a47355c8031b2c
parentdev-libs/libgusb: Version bump to 0.3.6 (diff)
downloadgentoo-b92f332b.tar.gz
gentoo-b92f332b.tar.bz2
gentoo-b92f332b.zip
app-text/iso-codes: Version bump to 4.6.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-text/iso-codes/Manifest1
-rw-r--r--app-text/iso-codes/iso-codes-4.6.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 8d557acc8e6f..0460a53cc334 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1,2 +1,3 @@
DIST iso-codes-4.4.tar.gz 13299605 BLAKE2B 485f3b0240f1892fb96f2b5c391b3f0adc593fac97d53748aa104208936d1bf81de1d40e742ab48e3663cea0ce5b28a20782df2f4eed251bab5b8a7055745d0e SHA512 d22ecdef75cd07b59ea0dbc87d25eb254676ab83297c1a43dbad9d3471ba355630f5588b4590972526f9e885b2e1ec307303ac0bb94b2dd5c707377c1cfa64d8
DIST iso-codes-4.5.0.tar.gz 13635723 BLAKE2B e96cbf80a93fd4901decd59006e51b39eb35b64b6ead28c0f0f1b0103f341dd79849db07f63be16154e5041a85a563d477b6470143ad325f1d25880d539807d0 SHA512 457585de1bfb848bbdbd15754588e690e3214f5d4442c32df4044f8a5b2cf6035c9c0cea84cc9b6e6ef093c0e9c8f7317e5bea920060b09d121b042e66046ca5
+DIST iso-codes-4.6.0.tar.gz 14089611 BLAKE2B 0e85ca49dd40ca053af4b06aca440e55c2b9bb2061fcdceaa25b31ac7fd7942a590756db90c10db64e5e1ffcedbce5a552e60a6d495bb9d60621bc7b862e630b SHA512 fcee802a3f92ef035371ff45fa9d8acbf1e2f490e38d84d2e27d2226d250ad02d088156d0889c0fc0fc09f30c4541b30dc7eb65ca4f40c3764599c1b2143013f
diff --git a/app-text/iso-codes/iso-codes-4.6.0.ebuild b/app-text/iso-codes/iso-codes-4.6.0.ebuild
new file mode 100644
index 000000000000..606b0e7ba92b
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.6.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_BD bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fil fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kn ko kok ku kv kw ky lo lt lv mai mhr mi mk ml mn mo mr ms mt my na nah nb nb_NO ne nl nn nso nv oc or pa pap pi pl ps pt pt_BR ro ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif tzm ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/${P}/${PN}-${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-${P}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+DOCS=( ChangeLog.md README.md )
+
+# l10n_find_plocales_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}