summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-02 18:51:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-02 19:37:42 +0200
commitb938e53f8bb0ffff0fd009113efe46483a12fdd3 (patch)
treeff889948e8a49372af342c7620cc37f6f73db29f
parentdev-python/requests-cache: Bump to 0.9.6 (diff)
downloadgentoo-b938e53f.tar.gz
gentoo-b938e53f.tar.bz2
gentoo-b938e53f.zip
dev-python/json5: Bump to 0.9.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/json5/Manifest1
-rw-r--r--dev-python/json5/json5-0.9.10.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index b806c67b195c..d49c0218e1d8 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1,2 +1,3 @@
+DIST pyjson5-0.9.10.gh.tar.gz 111356 BLAKE2B 457bce2988d9e5848784fbd0c75603aa77b7f5d08c71f9849f7459728985ee69085bd5d0d471ae1d9c2291fa2293eedc4be2535da333821a77b01ba3d7e9c1bc SHA512 5e5b04739a47c64b642060a969b11547a7f5490ec9031d526bf90d838f1879958f1fae61644f5ecf67a936dcb7b57ce18de3ee86bece44204758d0eff5e5b8ed
DIST pyjson5-0.9.8.gh.tar.gz 110629 BLAKE2B 7a2acfbf1228e8f143a19775750e6d020376d63b2b036eac75be032b7baed1e6b93ea3ee842b0c200db6f44dc0f16f3c6c2f18cb165b24918334a48f237f2a9f SHA512 e1fb7a7457bdc68c33e2d73ddae8913aeec6f001e25a70234f7233d8d28b8eee8dd023c76e26dec0d0a2051e8e2cd731044dbe7dc15af9ec95f0ce806fabac72
DIST pyjson5-0.9.9.gh.tar.gz 111214 BLAKE2B ccf329ea148e576655b1fb24124c813d31e117291cdfc53affa02542330b11c136cd28e74418351a30478249c8f4c109be6547d69e423c8c7b5f96f77ef5daac SHA512 cd28c64708738484376a03908ec75b30bee44a8834a1e9dbe81be98a6f46ba75600d6f958c6298998f373125589209907f5e8b63714ed6a83bb7a1d27adbccd5
diff --git a/dev-python/json5/json5-0.9.10.ebuild b/dev-python/json5/json5-0.9.10.ebuild
new file mode 100644
index 000000000000..0a10cb1d1bee
--- /dev/null
+++ b/dev-python/json5/json5-0.9.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest