summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-09 08:32:55 +0100
committerSam James <sam@gentoo.org>2023-07-09 08:34:20 +0100
commitb93f752846523c7e94dc0efac07c2225c7d7d5de (patch)
treed89393d7bc6da13beb79833855a2a29996c2f956
parentdev-python/numpy: add 1.25.1 (diff)
downloadgentoo-b93f752846523c7e94dc0efac07c2225c7d7d5de.tar.gz
gentoo-b93f752846523c7e94dc0efac07c2225c7d7d5de.tar.bz2
gentoo-b93f752846523c7e94dc0efac07c2225c7d7d5de.zip
sys-apps/moar: add 1.15.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.15.3.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index b264f40416e1..5f210682e1ed 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -4,3 +4,5 @@ DIST moar-1.15.1-deps.tar.xz 4808044 BLAKE2B cd7808337af5acb2bd6cb4b9696c9d04803
DIST moar-1.15.1.tar.gz 2780649 BLAKE2B 79145ae426f5ae77d73dd556521135bfad21af3841818c4092eb476a52b408da86a4ce1f4c8e43712e74be233b7fc9469788e2134c866e8bb8ba83927c7f4f2d SHA512 c58fc57f583e8051c3e1f567e9d8ad0aca45dcbfb1998d0156cb07b90bc2359d70c8fe90849f753f969980af919d9faef82cde7dedcf2aa9aeab4c080edc7752
DIST moar-1.15.2-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
DIST moar-1.15.2.tar.gz 2780812 BLAKE2B c104349cb94399f2c0c4a3219f2d59020cb7a9fa445edcde639c706070cae38ce54c7f181a0bf2de3ee831c146aaa19effbabf76509bfae948a22771951c0e34 SHA512 b4b7afa1b884a50e3939b59174e610357c6259667d3cac190aab24c5991bf59ff617200f04ec7292fd7eebf36a828748c54ce2eccbbe0cc413f3e0b5994d8cf4
+DIST moar-1.15.3-deps.tar.xz 4760036 BLAKE2B 6fd72d710a620fdf104766be84f3fa68652c760818cdee66bb8475cc8949872c82be026c04b54cb61c0108c5977cb1f787f9a4fa0316bde0293cdedb1f6f94f8 SHA512 f40520a1b2e94f4a3e97d6a4e19191484b66e13a57c7b30416c813d84cad3d29295e862d5b75870313cc905112425c731d052619d49e78b33fb3d5d8750df3df
+DIST moar-1.15.3.tar.gz 2781596 BLAKE2B 36e908245fbdebb89e2ed5cc1ef80c2000aeb03d8f35b84dff6d7e8b270d337d3dec9829d718d576e6ca4b0a6ac8694c5fa72b167a67dd3e7cde97ff06f7bfc5 SHA512 cce9eef06af14c320527a1b6a1832608b8267b9453eafb1153677aea98372e3fc3800e2a8938e9460e0f914c72f5c31380a0ee8ff0bd7db903756bea5352b424
diff --git a/sys-apps/moar/moar-1.15.3.ebuild b/sys-apps/moar/moar-1.15.3.ebuild
new file mode 100644
index 000000000000..a32bbea5ec05
--- /dev/null
+++ b/sys-apps/moar/moar-1.15.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI=" https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}