summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-01-03 12:21:29 +0400
committerJason Zaman <perfinion@gentoo.org>2016-01-03 12:24:11 +0400
commitb9415cc4604197d40b5924e4ad2ffc4d32bf68c0 (patch)
treebcaff7d690931358cfdfe715827e3ccbcf0715c0
parentdev-ruby/ruby-poppler: fix compilation with new poppler, bug 570634 (diff)
downloadgentoo-b9415cc4.tar.gz
gentoo-b9415cc4.tar.bz2
gentoo-b9415cc4.zip
www-servers/uwsgi: Add selinux policy rdep
Package-Manager: portage-2.2.26
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.11.2-r1.ebuild5
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.12.ebuild5
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.9.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/www-servers/uwsgi/uwsgi-2.0.11.2-r1.ebuild b/www-servers/uwsgi/uwsgi-2.0.11.2-r1.ebuild
index 6d0efd1dfbf3..2e0167a5196b 100644
--- a/www-servers/uwsgi/uwsgi-2.0.11.2-r1.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.11.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -56,7 +56,7 @@ LANG_SUPPORT_EXTENDED=( lua php pypy python python_asyncio python_gevent ruby )
# *java*: TODO
# v8: TODO
# matheval: TODO
-IUSE="apache2 +caps debug +embedded expat jemalloc json libressl +pcre +routing +ssl +xml yajl yaml zeromq"
+IUSE="apache2 +caps debug +embedded expat jemalloc json libressl +pcre +routing selinux +ssl +xml yajl yaml zeromq"
for plugin in ${UWSGI_PLUGINS_STD[@]} ; do IUSE="${IUSE} +uwsgi_plugins_${plugin}" ; done
for plugin in ${UWSGI_PLUGINS_OPT[@]} ; do IUSE="${IUSE} uwsgi_plugins_${plugin}" ; done
@@ -123,6 +123,7 @@ CDEPEND="sys-libs/zlib
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-uwsgi )
uwsgi_plugins_rrdtool? ( net-analyzer/rrdtool )"
want_apache2
diff --git a/www-servers/uwsgi/uwsgi-2.0.12.ebuild b/www-servers/uwsgi/uwsgi-2.0.12.ebuild
index cd170b2d9b29..ec8caf052291 100644
--- a/www-servers/uwsgi/uwsgi-2.0.12.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -56,7 +56,7 @@ LANG_SUPPORT_EXTENDED=( lua php pypy python python_asyncio python_gevent ruby )
# *java*: TODO
# v8: TODO
# matheval: TODO
-IUSE="apache2 +caps debug +embedded expat jemalloc json libressl +pcre +routing +ssl +xml yajl yaml zeromq"
+IUSE="apache2 +caps debug +embedded expat jemalloc json libressl +pcre +routing selinux +ssl +xml yajl yaml zeromq"
for plugin in ${UWSGI_PLUGINS_STD[@]} ; do IUSE="${IUSE} +uwsgi_plugins_${plugin}" ; done
for plugin in ${UWSGI_PLUGINS_OPT[@]} ; do IUSE="${IUSE} uwsgi_plugins_${plugin}" ; done
@@ -125,6 +125,7 @@ CDEPEND="sys-libs/zlib
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-uwsgi )
uwsgi_plugins_rrdtool? ( net-analyzer/rrdtool )"
want_apache2
diff --git a/www-servers/uwsgi/uwsgi-2.0.9.ebuild b/www-servers/uwsgi/uwsgi-2.0.9.ebuild
index d378ed1368a5..4d7251d187fc 100644
--- a/www-servers/uwsgi/uwsgi-2.0.9.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -56,7 +56,7 @@ LANG_SUPPORT_EXTENDED=( lua php python python_asyncio python_gevent ruby )
# *java*: TODO
# v8: TODO
# matheval: TODO
-IUSE="apache2 +caps debug +embedded expat jemalloc json +pcre +routing +ssl +xml yajl yaml zeromq"
+IUSE="apache2 +caps debug +embedded expat jemalloc json +pcre +routing selinux +ssl +xml yajl yaml zeromq"
for plugin in ${UWSGI_PLUGINS_STD[@]} ; do IUSE="${IUSE} +uwsgi_plugins_${plugin}" ; done
for plugin in ${UWSGI_PLUGINS_OPT[@]} ; do IUSE="${IUSE} uwsgi_plugins_${plugin}" ; done
@@ -118,6 +118,7 @@ CDEPEND="sys-libs/zlib
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-uwsgi )
uwsgi_plugins_rrdtool? ( net-analyzer/rrdtool )"
want_apache2