summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-23 03:47:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-23 04:00:04 +0100
commitb949bc23f0d9eb9a641b9f9b5bf24dfbc441b623 (patch)
tree802d7709b27b661fb06e952d48359754719af247
parentapp-containers/earthly: drop old 0.7.22 (diff)
downloadgentoo-b949bc23f0d9eb9a641b9f9b5bf24dfbc441b623.tar.gz
gentoo-b949bc23f0d9eb9a641b9f9b5bf24dfbc441b623.tar.bz2
gentoo-b949bc23f0d9eb9a641b9f9b5bf24dfbc441b623.zip
app-containers/earthly: bump to 0.8.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 14697922b725..19bd10e33bc9 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,2 +1,4 @@
DIST earthly-0.7.23-deps.tar.xz 157140928 BLAKE2B 493c7dce3e79f94659e99501020c07232a2d6ff78a055209b1b42be8615e38e01dacef4ceb50a80ed26e597de4dbb892fee2d54f6721fd5af62c86a0a9197d45 SHA512 a278077be794a1085105271fc3e031c02079e2b4f45c7220b3114df72ba26758758d5c0f1171ff861feb1c305765952494bf1afe95dcc469d2b9c6aad13fe7b9
DIST earthly-0.7.23.tar.gz 8023353 BLAKE2B 458850b26a2730eb10ae3912f249d6ba9fdf81ed0c734f568ebf2cbaf5da005d258d38a089d452d42628d071d0b07f73e4f73cb29e7a02c406c1ea394d22ae97 SHA512 be524a6ab86ad3cff307d990f3645007cde673383cbaf132ebc6ab9e7052e8d13e163e958353041151d9fe6dc987ab75372dbf061a8413a932408a844cfe1007
+DIST earthly-0.8.0-deps.tar.xz 158417236 BLAKE2B 998240c6065dd46eebc311975fa98e657a9568b6e26f0113d00e2f55b1cea8b017425fb6cafa7a7a5d7dd2ccdbaf711cee62b5a98d92322f9ff8a6458bb31a02 SHA512 1fd31f82acb7862a4deff611f088b73fd15e04a2bf56d91dff955ffb4c3c54425f6011b7a2bcf94fbb721ea820cc3728f8038870eb073c6d12d435406167dc8b
+DIST earthly-0.8.0.tar.gz 8029214 BLAKE2B 1ca0afa4e92a05fca47ada6a6b74d789fb9571b0e92cc7bbb0ccc88930a128db76382b3e5137073ebd82f74fb8d43b81f8e6d056a08e6fa73978f23b680b36e2 SHA512 661c1e15cf8943dfcd8d55c36191f4f9da6dc705bb894194ff0a31733038f7b74d2b187a066c6a6cc329a9a89f362299f1de3b370f273ce87e2e3cdd2b4c8163
diff --git a/app-containers/earthly/earthly-0.8.0.ebuild b/app-containers/earthly/earthly-0.8.0.ebuild
new file mode 100644
index 000000000000..ebf995573dfa
--- /dev/null
+++ b/app-containers/earthly/earthly-0.8.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
+if [[ "${PV}" == 0.8.0 ]] ; then
+ COMMIT_SHA=c23e2735fdceeb3f17bae3746a05cbc8e98fafe3
+else
+ die 'Could not detect "COMMIT_SHA", please update the ebuild.'
+fi
+
+inherit go-module
+
+DESCRIPTION="Build automation tool that executes in containers"
+HOMEPAGE="https://earthly.dev/
+ https://github.com/earthly/earthly/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+src_compile() {
+ mkdir -p bin || die
+
+ local go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
+ local go_ldflags="
+ -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
+ -X main.GitSha=${COMMIT_SHA}
+ -X main.Version=v${PV}
+ "
+ local -a go_buildargs=(
+ -tags "${go_tags}"
+ -ldflags "${go_ldflags}"
+ -o bin
+ )
+ ego build "${go_buildargs[@]}" ./cmd/...
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/earthly
+ newexe bin/debugger earthly-debugger
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ if has_version "app-containers/podman" ; then
+ ewarn "Podman is supported but not recommended."
+ ewarn "If issues arise, then please try running earthly with docker."
+ fi
+
+ if has_version "app-containers/podman[rootless]" ; then
+ ewarn "Running podman in rootless mode is not supported because"
+ ewarn "earthly/dind and earthly/buildkit require privileged access."
+ ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
+ fi
+}