summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-28 06:52:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-28 07:32:45 +0200
commitb96b73cd04517ce02e253b197936cdfed7b06179 (patch)
treec989cd6649e6b683d04bcc7bd6f506031962f376
parentdev-python/sphinx: Bump to 7.1.1 (diff)
downloadgentoo-b96b73cd04517ce02e253b197936cdfed7b06179.tar.gz
gentoo-b96b73cd04517ce02e253b197936cdfed7b06179.tar.bz2
gentoo-b96b73cd04517ce02e253b197936cdfed7b06179.zip
dev-python/async-lru: Bump to 2.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/async-lru/Manifest1
-rw-r--r--dev-python/async-lru/async-lru-2.0.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/async-lru/Manifest b/dev-python/async-lru/Manifest
index 6a288f18ddc6..cab249d7fec0 100644
--- a/dev-python/async-lru/Manifest
+++ b/dev-python/async-lru/Manifest
@@ -1 +1,2 @@
DIST async-lru-2.0.3.gh.tar.gz 12592 BLAKE2B 3b434ebcb5f4db754ca93dae3e597490b07ce6d84d573529343a540b77fc9116f329f641fb97639dce6903384e52433dc48aabb7927266e8bcc18ce9fbaa85ac SHA512 8a3685bccb09ae268a713b3796f1f945bc9f9beff14530eb997722c6a0546bb39860492eadc1a46fca6ed549352e20cd9983396127ee9edfbd50657b5e5dd58f
+DIST async-lru-2.0.4.gh.tar.gz 13084 BLAKE2B dc3316e63783f36a446fc0d3565e018340787822b4a2663b9759d8bf5222277526b9a1285a34c3d84ccd245f75c6a53d9a693cc13c2b101bcb4bc97fa31835bf SHA512 aed4a043bfb323c1fc01f93def11fe597141778bd8437bd90189e2b6da26b0bb412fa72fb0d12a40b771571f3cb5f06fed8302379aec2e8e0318eab179b64912
diff --git a/dev-python/async-lru/async-lru-2.0.4.ebuild b/dev-python/async-lru/async-lru-2.0.4.ebuild
new file mode 100644
index 000000000000..0e1f63516ebd
--- /dev/null
+++ b/dev-python/async-lru/async-lru-2.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple lru_cache for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/async-lru/
+ https://pypi.org/project/async-lru/
+"
+SRC_URI="
+ https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}