summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-10-03 19:52:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-05 23:39:30 +0200
commitb97641090928d5e472e4c6b887f58b9283e6cd5e (patch)
tree0e700afdac762fb926d72a85969f9493bda82c62
parentapp-admin/ulogd: remove old (diff)
downloadgentoo-b9764109.tar.gz
gentoo-b9764109.tar.bz2
gentoo-b9764109.zip
net-misc/jlj: EAPI7 revbump
Closes: https://bugs.gentoo.org/667664 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10056 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-misc/jlj/jlj-2.12-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/jlj/jlj-2.12-r1.ebuild b/net-misc/jlj/jlj-2.12-r1.ebuild
new file mode 100644
index 000000000000..5534c8e01b5a
--- /dev/null
+++ b/net-misc/jlj/jlj-2.12-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple console LiveJournal entry system"
+HOMEPAGE="http://umlautllama.com/projects/perl/#jlj"
+SRC_URI="http://umlautllama.com/projects/perl/${PN}_${PV}.tar.gz"
+
+LICENSE="freedist"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+DEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ newdoc .livejournal.rc livejournal.rc
+ dodoc README.JLJ
+}
+
+pkg_postinst() {
+ elog "README.JLJ and a sample livejournal.rc have been installed to"
+ elog "/usr/share/doc/${PF}/"
+}