summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-16 14:34:44 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-16 14:34:44 +0100
commitb9974fe114e7fdd61af7186e6cdb0e9a13dde71a (patch)
treedf8cd038c39a01e876fe746ed2b5829394e1bf4f
parentxfce-extra/xfce4-power-manager: Remove old (diff)
downloadgentoo-b9974fe114e7fdd61af7186e6cdb0e9a13dde71a.tar.gz
gentoo-b9974fe114e7fdd61af7186e6cdb0e9a13dde71a.tar.bz2
gentoo-b9974fe114e7fdd61af7186e6cdb0e9a13dde71a.zip
app-vim/gentoo-syntax: Bump to 20201216
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20201216.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 05ad58ebd740..65a504ad5848 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-syntax-20200120.tar.bz2 18593 BLAKE2B c29dd3b3896bdb78e5c07b40474434c5ba6fa8b3a89f8ec237136d0474e8eaace8a72c7e3974ff63eaa24d3e57a1e61785bfc7889a93f7263ef9387caa651936 SHA512 ab57707b4a44f33c085a39eb745ca206312d84ca49680e24a462eb75d65cc37694a545f4a31b4ee2919d0f6b30276ce25f6caa7e20782511c7534bf2319e8a4f
DIST gentoo-syntax-20201007.tar.bz2 18645 BLAKE2B 5ec28f03dde8d0be7dc24b337fabc02b0fbd53f4a97e4f22b9d042c0d3631f1be3a1e6e7d270b39e43688eb414f04525014acc3ac6e450dc9737341471fc15a7 SHA512 7b5554fdc68616177c906f6185c7c0843a75aac14ed28516d86ab7a37f67c5934e84c15b88c23e39c34665c1a3bb43deeff53e09ec665a4b4822309f77110ca9
+DIST gentoo-syntax-20201216.tar.bz2 18631 BLAKE2B 9b68329ae2a64fba1d2a7a9fa6bb60b3a982dc2ebd5b84cf4d95052b3c8c138d7789a25c571e16cde371248e27dd8b28a7b73874749ec26e165724a43bbfaa9e SHA512 f7a6967c28aa669c8bfb114b0c60d52d970b68cd5b02a44f165f85ed5d8f42cff97ceccf4011481a84ab131c06f02725b4d9b53e3cbc0dc116dccb4ce55bd2f6
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20201216.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20201216.ebuild
new file mode 100644
index 000000000000..4651f7723a99
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20201216.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}