summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-17 07:09:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-17 08:40:49 +0100
commitb9c232290976c1568d57372cea45e8fdbd738d27 (patch)
treef42880336b0d127d6eb2f52fc2e95a431387412c
parentdev-python/botocore: Bump to 1.34.20 (diff)
downloadgentoo-b9c23229.tar.gz
gentoo-b9c23229.tar.bz2
gentoo-b9c23229.zip
dev-python/boto3: Bump to 1.34.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.20.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 4a84f72345b4..0f7b8905d45c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.34.11.gh.tar.gz 760539 BLAKE2B 8ce756d33b604aed9d42bcccf60be467bd51
DIST boto3-1.34.14.gh.tar.gz 762792 BLAKE2B 87857a6ff7e19f8438fe6b57978cdb3c8d22f8a68008fad4fcfdd40358b919a1c45f810bc45637da5971d20ce221cd8343440663d072666349e32c4df2be97a2 SHA512 8b651c5946394e159d6dd719337e4a5a60f708fa22ef26026bd85a18b3f34efa06f71282b9e9ea8c8ad4995e4bd6d0c13e4dddac75a51922fc30154ac0b87ecb
DIST boto3-1.34.18.gh.tar.gz 765458 BLAKE2B 29414e20fa034f63c899b6f2d5460d8973dd617aa97adbe1940daaf3f4a08cf9286bf24709fe9bcd745fdec8415578a87033f99cfd1335baa8ecf29f1723074d SHA512 aa5dc9363d3f04f49a40ea352ab75a30b52e9b1aa1153ab4ed9d6bef6059ea6cb0cb04301158f0e857d9abd19c670db447dda6cd9d8898d6c71c0b69242775fc
DIST boto3-1.34.19.gh.tar.gz 764452 BLAKE2B c0388452728e54cdded0a9944e37e6725e8150b242c8e91ce812aed29a1316ce59e880d5e466e956d9c3dafcea99996801d90a1bfdef2b4eed9852f6dd861f0b SHA512 bad2a283c7c829f1de661c19058b963bfe2dca5e71513729f6099a4102d130a48e5095e44877d29e73308c8104f667229ba402503d4eba287ae975f4cef18c29
+DIST boto3-1.34.20.gh.tar.gz 766685 BLAKE2B e68cb60bdbec6ccd4e5ec1c1ae116c0cdb952862902c5e38788ea735083f515a89923b7056f862cffdd40bd967ca717a2387537f1e17bb0f76a9bf49ecb39fc8 SHA512 a2c8bc7f09571f27c45595c15794a8125a23317a785d7e8ea296455b2f63e8375fd818906bf28c6788ff65dd6d40a2abd28aaf8ef4a22fe80a56d01c6464585b
diff --git a/dev-python/boto3/boto3-1.34.20.ebuild b/dev-python/boto3/boto3-1.34.20.ebuild
new file mode 100644
index 000000000000..037a85ad96ee
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.20.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}