summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-20 11:51:30 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-20 11:51:30 +0300
commitb9c91185ba48ed4fa2360a143cd17cc9a560207a (patch)
tree01a6364c9e7e27019b4ed281cc3aa2061a47dced
parentapp-admin/keepass: version bump 2.49 (diff)
downloadgentoo-b9c91185.tar.gz
gentoo-b9c91185.tar.bz2
gentoo-b9c91185.zip
dev-python/owslib: add 0.25.0, enable py3.10
- enable tests as network one - use pytest directly - cleanup of deps Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/owslib-0.20.0.ebuild13
-rw-r--r--dev-python/owslib/owslib-0.25.0.ebuild39
3 files changed, 50 insertions, 3 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index 8164041e6fb0..052cb195f61d 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1 +1,2 @@
DIST owslib-0.20.0.tar.gz 912319 BLAKE2B 9f6e44f76554d67756839bfad1cdce6e2e7a4db6c3517ed308256745a3ea1df77488718f307bcd59dfcae7bab7801ba1974131f358db1bd070846640ccf08ada SHA512 c30e14d0a310617d2dbcca436f38d4a942b8c5efb96506554e650b20b34580fd0119ae6bf17892bb09ceff7141b9cbfd32deb582d14d81b6518dbbc223116d07
+DIST owslib-0.25.0.tar.gz 936550 BLAKE2B 9cb34a6c7c93dc89a466c13351d457c9372d405055fa3f6cec9c05c231e76762168c6813085523037b3a6439100500c46c1044569bd2bb598c3e2e63757d8b86 SHA512 058108cf77197ce24793608869d56bf0467230f5f231ac9ba48445f2e02d07ea1e26be03ad6967504a1e625008ae2768ed2a663f3b7a49dcea410ee4a8b40cec
diff --git a/dev-python/owslib/owslib-0.20.0.ebuild b/dev-python/owslib/owslib-0.20.0.ebuild
index 7349839b7ad3..a5f26d6321dc 100644
--- a/dev-python/owslib/owslib-0.20.0.ebuild
+++ b/dev-python/owslib/owslib-0.20.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
@@ -34,9 +34,16 @@ DEPEND="
"
RESTRICT="test" # tests require WAN access
+PROPERTIES="test_network"
PATCHES=( "${FILESDIR}/${P}-no-privacybreach.patch" )
+src_prepare() {
+ sed -e '/addopts/d' -i tox.ini || die
+ distutils-r1_src_prepare
+}
+
python_test() {
- "${EPYTHON}" "${S}/setup.py" test || die
+ epytest --tb=native --ignore=setup.py --doctest-modules --doctest-glob 'tests/**/*.txt'
+ #"${EPYTHON}" "${S}/setup.py" test || die
}
diff --git a/dev-python/owslib/owslib-0.25.0.ebuild b/dev-python/owslib/owslib-0.25.0.ebuild
new file mode 100644
index 000000000000..0ff537b66057
--- /dev/null
+++ b/dev-python/owslib/owslib-0.25.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="https://geopython.github.io/OWSLib/"
+SRC_URI="https://github.com/geopython/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/OWSLib-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/pillow[${PYTHON_USEDEP}] )"
+
+EPYTEST_DESELECT=(
+ tests/test_ogcapi_features_pygeoapi.py::test_ogcapi_features_pygeoapi
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i tox.ini || die
+ distutils-r1_src_prepare
+}