summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-18 09:44:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-18 10:48:30 +0200
commitb9d0f3757fd50ed7b2a9a14ae793e84727f86e66 (patch)
tree76aff7a6198d22b917503fd7ff2814fd46529f58
parentdev-python/botocore: Bump to 1.20.74 (diff)
downloadgentoo-b9d0f3757fd50ed7b2a9a14ae793e84727f86e66.tar.gz
gentoo-b9d0f3757fd50ed7b2a9a14ae793e84727f86e66.tar.bz2
gentoo-b9d0f3757fd50ed7b2a9a14ae793e84727f86e66.zip
dev-python/boto3: Bump to 1.17.74
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.74.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 7309911995a4..d1e6e2e3cbc3 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -9,3 +9,4 @@ DIST boto3-1.17.70.tar.gz 369851 BLAKE2B 31416aed68f340842962dca12f77e169f87f2f2
DIST boto3-1.17.71.tar.gz 370105 BLAKE2B d0ea164459e7f79f5d9124af1917eb1a6ef9743792cd13daf58f8c70c852e537392ae8e3fb7ddaf5cea75e914ebb44c205f865f1b896827322b0be8500dc4a4f SHA512 b934ee87fbbced5a6c180517eb2b304b0d097dabc7f9831ebd4945d1b69919e3701955d92b4cfa5cd00da42f32fce731b70dfb3f69b5583eba0a032b4ef3505d
DIST boto3-1.17.72.tar.gz 370275 BLAKE2B 2a6923fb9ca0a67e9096844cf66a3dbf74e77eb1b4ade6f17fc248dff5249b467bf07bfe51779a65dcc9d41f20597419418cb7aca04cf03b3ab7c6556772b685 SHA512 c185c05c590d6e7d61db6ea88082a1520229fb9384eb04e0d0c19108cb3cbab53714dcc46b0de064e11e8989036e782f21d687dc12312a019717dbf082febe35
DIST boto3-1.17.73.tar.gz 371093 BLAKE2B 1259a4c8ad0c87cae66c6f30c70ea785927669f82ba3fe196db30e7dd8c92f940928a25c4cb263d3b9f0c9944a4dbf8d0cd4dc52770d60286a50ca4830d3129a SHA512 582ced34557e3ce20628a5093c80f7a9231e010da4a9c4f7669b7c04f1eae8c4edf050b75fc00675f03d4e9fbb3dbd97441cd9a99c7e050a3914f072810a8aeb
+DIST boto3-1.17.74.tar.gz 371719 BLAKE2B f6d44206a14cdf395c8963be048e81391ecbf6817b1c00e1cd081abf111df8bd85c05fa1c04b013de7e6d916835e4876cc961891c8d52d8a32e41713080ed96e SHA512 a79012072238286561ab43ca7bb9f24236e858e0bf550be9a074517145445d0d520cc207683d99f6f704416f617b5f89468c87357223db9564e4310a2a2676f1
diff --git a/dev-python/boto3/boto3-1.17.74.ebuild b/dev-python/boto3/boto3-1.17.74.ebuild
new file mode 100644
index 000000000000..359c82c2155b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.74.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}