summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-29 22:37:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-29 22:38:08 +0000
commitb9d9ecb23fce8499407370eace81ca9544970345 (patch)
treef4f221e9cd799d512a693b1077cb81035fd0e9b5
parentx11-misc/synergy: Update remote-id (diff)
downloadgentoo-b9d9ecb2.tar.gz
gentoo-b9d9ecb2.tar.bz2
gentoo-b9d9ecb2.zip
sys-devel/crossdev: bump up to 20201129
Single new change: - explicitly avoid USE=hardened for gcc on mingw targets Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20201129.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 201750c3fbfe..ac7022918db0 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,2 +1,3 @@
DIST crossdev-20200801.tar.xz 28268 BLAKE2B 36f22a2d1422d5f9e27a5559a8c141462853c4dc011ec98c66d235ef262ea9408fd5054b578963fd17ef630ea63e72c068d216f6ffbea7d191d1374a6ecc4033 SHA512 331af1525cdfc66380621b764bfc63178ce962b9071408d1ee08480caad9c0e4782a8fa5e5f3500fd2ea03ccd322895cc95d80106ad9e5b97a0e09ef5d88c94b
DIST crossdev-20201122.tar.xz 28308 BLAKE2B 66da19024dd03e98ff0f388cdb9bf76a968ef4ac920249e9a782d46c1d32a4cb3047a0aa2d9619a054b9894ef30624ce99bb45f9c45b937fbb280a8a298aede8 SHA512 bbd7ab6a8ea0d2cb13f822277d9b8c19478368b2f365aaa60bd2548b47f9e7a582805593b683631ebb20bfb6d2f496f2d3a5eb6d144207fab58607565a8d1a41
+DIST crossdev-20201129.tar.xz 28372 BLAKE2B b59d94a69b83f8db9193bd54ff6059b20617b6dd60c0f9a0ec5acdf4b93adf747886598b9af7d69d2fd9705fab709041a96c149286e623b6557ea709bf2f840a SHA512 7b49795ea266d90e45c48b092bffa485a7207c66550d797297cb7e0756f7c497d045b3cb9b90f50b80a3ada4916a3ba273b2c19b9d02c834fb47d906efe3a8ba
diff --git a/sys-devel/crossdev/crossdev-20201129.ebuild b/sys-devel/crossdev/crossdev-20201129.ebuild
new file mode 100644
index 000000000000..809478863946
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20201129.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}