summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-06-26 11:34:28 +0200
committerJeroen Roovers <jer@gentoo.org>2016-06-26 11:34:28 +0200
commitb9dd165c8a0086769aa29ff5368c4d85f6bd6976 (patch)
treedb4a66a258304822107a4186a8c28a5af0170242
parentmedia-libs/faad2: Specify LICENSE more precisely. (diff)
downloadgentoo-b9dd165c.tar.gz
gentoo-b9dd165c.tar.bz2
gentoo-b9dd165c.zip
x11-misc/rofi: Version bump.
Package-Manager: portage-2.3.0
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.1.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index b8f1f57177bd..1e5d94dd450c 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1 +1,2 @@
DIST rofi-1.0.1.tar.xz 183700 SHA256 6718508cef6fc1c1e91000380357341aa5556f6cc7aafbec3d9c91b913ad5d06 SHA512 18001ae084e6148d91a1cb6176d44af3d916e24a11abbfdcf7104f8c9909b8172420a271760322b8354b6790e720f819ba75c3df13f011ed4cb280d0e65ef618 WHIRLPOOL a04ecc0ff45f701c3035aef2eecc7f75c08aff5cbcb3b494cb5bf7d30aac93dfb8b6e86c87e36eacd5752f176a580bebfd19193377a59c8bf47c8cc67263b1f9
+DIST rofi-1.1.0.tar.xz 188768 SHA256 1622eca87566baa98d087500b069c7241627d230ef6217990f0bc4032ba01bd1 SHA512 a31d3102e0cc31de2191581cd7a1d4b7ea6eb986535fc37978ac1c5a335ca5b6fe68441056b63cf99530c6219198f2aa4b2ed1b7be1c0eaca9b46082a4169321 WHIRLPOOL 5622896abe81ea915a760037201ae20fb9071118b215694f7e69227d54637a68339f6eed1a71e6fe4d7bdc8b08e996237a958aedc92848aa756dca5ceca95730
diff --git a/x11-misc/rofi/rofi-1.1.0.ebuild b/x11-misc/rofi/rofi-1.1.0.ebuild
new file mode 100644
index 000000000000..da52108687df
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://davedavenport.github.io/rofi/"
+SRC_URI="https://github.com/DaveDavenport/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="i3 windowmode"
+REQUIRED_USE="i3? ( windowmode )"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ i3? ( x11-wm/i3 )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable windowmode) \
+ $(usex i3 '' --disable-i3support)
+}
+
+src_test() {
+ emake test
+}