summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-03 09:40:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-03 10:26:03 +0200
commitb9ede41d3a2fa8e8c67f221cdc6a37327209d85d (patch)
tree8bc4eaf54ac89bf43a3465ee5ba7b46b2803c5de
parentdev-python/zstd: Bump to 1.5.2.5 (diff)
downloadgentoo-b9ede41d.tar.gz
gentoo-b9ede41d.tar.bz2
gentoo-b9ede41d.zip
dev-python/pyzotero: Bump to 1.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.5.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index f2ea12214ce9..f6404d90cda9 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1 +1,2 @@
DIST pyzotero-1.5.3.tar.gz 525734 BLAKE2B 11de38c1954478ed9918f33bdbf550d6d0eda99a6e38154361c2da336158bacfaf16f1d9bb9ff08550e6951c3e29efe50618c78672bfcec6237bc42e6b52c6c5 SHA512 b31872db4a2fd53f6c17f6a33115ac762147810efae6f6351579a03f651f843e46b1d5f584cc47c1d20d8dad5c318d2835c2e053bc43f3063e84bce85658d9fb
+DIST pyzotero-1.5.4.tar.gz 525739 BLAKE2B 93acb725cb47e9f1642d88ea79e590e29af6eecedb5a14e220c9d6ce2c27d05dfd9042ef49d53c710a507050f566b097a272e025d26d1b10a64357e511da656e SHA512 10c27d531adf358c337aab3358d24e28318dfee02b08387663f0433fffc645ddc633929a8422d508952e26d29219c350c6865248c447391436d8cb5061f273ec
diff --git a/dev-python/pyzotero/pyzotero-1.5.4.ebuild b/dev-python/pyzotero/pyzotero-1.5.4.ebuild
new file mode 100644
index 000000000000..22190c083c5c
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="
+ https://github.com/urschrei/pyzotero/
+ https://pypi.org/project/pyzotero/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest