summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-04-02 00:53:11 +0200
committerSebastian Pipping <sping@gentoo.org>2018-04-02 00:53:15 +0200
commitb9f4dbd54803acb4ace2e270dc8fc222466d5a6b (patch)
tree570980ffafd4418f8ec2929a61ef563c54193005
parentdev-libs/libressl: version bump to 2.7.2 (diff)
downloadgentoo-b9f4dbd5.tar.gz
gentoo-b9f4dbd5.tar.bz2
gentoo-b9f4dbd5.zip
www-apps/nikola: Drop Python 2 support
The code is not fully compatible to Python 2 and upstream stopped supporting Python 2 officially quite a while ago. Package-Manager: Portage-2.3.26, Repoman-2.3.7
-rw-r--r--www-apps/nikola/nikola-7.8.14-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/www-apps/nikola/nikola-7.8.14-r1.ebuild b/www-apps/nikola/nikola-7.8.14-r1.ebuild
new file mode 100644
index 000000000000..05f442bd330a
--- /dev/null
+++ b/www-apps/nikola/nikola-7.8.14-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="Nikola"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="https://getnikola.com/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT Apache-2.0 CC0-1.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="assets charts ghpages hyphenation ipython jinja watchdog webmedia websocket"
+RESTRICT="test" # needs coveralls
+
+DEPEND=">=dev-python/docutils-0.12[${PYTHON_USEDEP}]" # needs rst2man to build manpage
+RDEPEND="${DEPEND}
+ >=dev-python/blinker-1.3[${PYTHON_USEDEP}]
+ >=dev-python/doit-0.29.0[${PYTHON_USEDEP}]
+ >=dev-python/logbook-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/mako-1.0[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/natsort-3.5.2[${PYTHON_USEDEP}]
+ >=dev-python/piexif-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-20.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
+ >=dev-python/yapsy-1.11.223[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ assets? ( >=dev-python/webassets-0.10.1[${PYTHON_USEDEP}] )
+ charts? ( >=dev-python/pygal-2.0.1[${PYTHON_USEDEP}] )
+ ghpages? ( >=dev-python/ghp-import-0.4.1[${PYTHON_USEDEP}] )
+ hyphenation? ( >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}] )
+ ipython? ( >=dev-python/ipython-2.0.0[notebook,${PYTHON_USEDEP}] )
+ jinja? ( >=dev-python/jinja-2.7.2[${PYTHON_USEDEP}] )
+ watchdog? ( ~dev-python/watchdog-0.8.3[${PYTHON_USEDEP}] )
+ webmedia? ( >=dev-python/micawber-0.3.0[${PYTHON_USEDEP}] )
+ websocket? ( ~dev-python/ws4py-0.3.4[${PYTHON_USEDEP}] )"
+# typography? ( >=dev-python/typogrify-2.0.4[${PYTHON_USEDEP}] ) # needs smartypants
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -rv "${D}/usr/share/doc/${PN}" || die
+
+ dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.txt
+ gunzip "docs/man/${PN}.1.gz" || die
+ doman "docs/man/${PN}.1"
+}