summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-04-16 17:51:47 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-04-16 17:51:58 -0700
commitb9ffc169a189e534b2d7bf0a3820fd3ea6252465 (patch)
treeaf7c2b0d2efb10182cc22dfeb095b73b4961a44d
parentsci-mathematics/petsc: fix missing build dependency (diff)
downloadgentoo-b9ffc169.tar.gz
gentoo-b9ffc169.tar.bz2
gentoo-b9ffc169.zip
app-text/lowdown: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-text/lowdown/Manifest1
-rw-r--r--app-text/lowdown/files/lowdown-0.8.4-configure.patch19
-rw-r--r--app-text/lowdown/lowdown-0.8.4.ebuild33
-rw-r--r--app-text/lowdown/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/app-text/lowdown/Manifest b/app-text/lowdown/Manifest
new file mode 100644
index 000000000000..ba3e9378cc09
--- /dev/null
+++ b/app-text/lowdown/Manifest
@@ -0,0 +1 @@
+DIST lowdown-0.8.4.tar.gz 520735 BLAKE2B dc66b92f285b186ca83b9fad1cccfef9b395233ef56756e9ea9071b5502cd81dc6ce2d67d7ef265dab8953010af0907cd76125cd4442cfbfc2bcf8c63e097809 SHA512 cd46ead69ed038bf3ccf848b784327d66c78dd8adbc9ae4bfee660b9b1e52844ac8c7ad0377f8f38a3fee0d2e523f979a22d6b547c7964304accef0951cfca34
diff --git a/app-text/lowdown/files/lowdown-0.8.4-configure.patch b/app-text/lowdown/files/lowdown-0.8.4-configure.patch
new file mode 100644
index 000000000000..aaecb129b2a1
--- /dev/null
+++ b/app-text/lowdown/files/lowdown-0.8.4-configure.patch
@@ -0,0 +1,19 @@
+diff --git a/configure b/configure
+index d1c16ab..941f185 100755
+--- a/configure
++++ b/configure
+@@ -92,12 +92,12 @@ LDADD_STATIC=
+ CPPFLAGS=
+ LDFLAGS=
+ DESTDIR=
+-PREFIX="/usr/local"
++PREFIX="/usr"
+ BINDIR=
+ SBINDIR=
+ INCLUDEDIR=
+ LIBDIR=
+-MANDIR=
++MANDIR="/usr/share/man"
+ SHAREDIR=
+ INSTALL="install"
+ INSTALL_PROGRAM=
diff --git a/app-text/lowdown/lowdown-0.8.4.ebuild b/app-text/lowdown/lowdown-0.8.4.ebuild
new file mode 100644
index 000000000000..6e601e6125f6
--- /dev/null
+++ b/app-text/lowdown/lowdown-0.8.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PV="VERSION_${PV//./_}"
+DESCRIPTION="Markdown translator producing HTML5, roff documents in the ms and man formats"
+HOMEPAGE="https://kristaps.bsd.lv/lowdown/"
+SRC_URI="https://github.com/kristapsdz/lowdown/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ virtual/libcrypt
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/lowdown-0.8.4-configure.patch"
+)
+
+src_configure() {
+ CC="$(tc-getCC)" ./configure || die "./configure failed"
+}
+
+src_test() {
+ emake regress
+}
diff --git a/app-text/lowdown/metadata.xml b/app-text/lowdown/metadata.xml
new file mode 100644
index 000000000000..cee379b15409
--- /dev/null
+++ b/app-text/lowdown/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>