summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-26 14:35:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-26 17:03:08 +0200
commitba07c517cfe4e1fc1b51477545e3aefcaad891d7 (patch)
tree1401481d7702fb55db547416c52681ef3af3e9ef
parentdev-ros/pluginlib: remove old (diff)
downloadgentoo-ba07c517.tar.gz
gentoo-ba07c517.tar.bz2
gentoo-ba07c517.zip
dev-ros/pluginlib: bump to 1.10.4
Package-Manager: portage-2.3.1
-rw-r--r--dev-ros/pluginlib/Manifest1
-rw-r--r--dev-ros/pluginlib/pluginlib-1.10.4.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/Manifest b/dev-ros/pluginlib/Manifest
index 9eac65ac2c0c..bb3fa03bdf22 100644
--- a/dev-ros/pluginlib/Manifest
+++ b/dev-ros/pluginlib/Manifest
@@ -1 +1,2 @@
DIST pluginlib-1.10.3.tar.gz 20554 SHA256 fca9f2f449ac7fea4eb4597d5ac8ac77d572f18f890333abd4cd2bbc0249f117 SHA512 01dd40edc1c29140de5f0fc9553d54daaeb4321c6117ec90bd89b55e66223dbdff98de5ae73b1210e9366b97cf9faa131252b165344eb75bd8e08a97cce7507d WHIRLPOOL 12c07d0c95d8d5da6d3debe0ed761cbc4e9b324dd8d93e44934d95897951d7bf96d3dc1b2a9989f8f5ae85a229831ebe2ac425687b3b460c70f234cff624d346
+DIST pluginlib-1.10.4.tar.gz 21420 SHA256 9a8a81d39472bda8cc8a9b189b9dc8f602b13b97a132a153144785d9fc5b68b2 SHA512 df469c6f536a062cadc5a4b38006bb407c10ab2bb4da19769ccfc46e466f1fa37216154a90fd41442ac35519eba420ad08f81bf9474511d1c5b4aca219a8b9de WHIRLPOOL b374959761d7fce017678c33fb8a44bbb960ff8002011573245f30f685dc2f48937cfda15fc515e71da1f8174b73c9cb3a66924e02d5e80f053563599dc355c4
diff --git a/dev-ros/pluginlib/pluginlib-1.10.4.ebuild b/dev-ros/pluginlib/pluginlib-1.10.4.ebuild
new file mode 100644
index 000000000000..b931f646f843
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.10.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/class_loader
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml
+ dev-ros/cmake_modules
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"